Cómo quitar #n/a de una fórmula en Excel [Resuelto/Cerrado]

-
Hola, QUISIERAS SABER COMO EVITO QUE EL RESULTADO DE UNA FORMULA EN EXCEL ME DE #N/A Y EN SU LUGAR ME DE CERO (0) O GUION (-)
Ver más 

9 respuestas

Mejor respuesta
142
Gracias
puedes usar esta opcion de ejemplo:

=SI(ESNOD(BUSCARV(C5,B5,1,0)),0,(BUSCARV(C5,B5,1,0)))


saludos

Deja un "Gracias" 142

¡Estamos felices de haberte ayudado! ¿Te hemos sido de ayuda? ¡Déjanos un comentario! Evalúa a CCM

CCM 19054 usuarios nos han dicho gracias este mes

-
ayuda quitar N/A a esta formula
=BUSCAR(B24,Inventario!B5:$C$8)
Mazzaropi
Publicaciones
1833
Fecha de inscripción
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
286 > victor murillo -
victor murillo, Buenas tardes.

Utilizar:
=SIERROR (BUSCAR(B24,Inventario!B5:$C$8), "")

Eso es lo que querías?
Espero haber ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
> Mazzaropi
Publicaciones
1833
Fecha de inscripción
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
-
COMO SE QUITA EL N/A A ESTA FORMULA ME AYUDAN GRACIAS
BUSCARV(A2,'[Salidas de Bolsa Ene 2017.xls]TD Etiquetado'!$A:$B,2,0)
Reymidas
Publicaciones
1
Fecha de inscripción
jueves, 15 de septiembre de 2016
Estatus
Miembro
Última intervención
jueves, 15 de septiembre de 2016
-
También puede quedar la fórmula:
=SI.ERROR(tu fórmula),"")
y en la celda queda en blanco, ya no aparece el error.
excelente, funcionó, gracias por tu aportación
27
Gracias
=si.error(escribes tú fórmula,0)

Saludos
muchas gracias, muy fue muy util, problema resuelto.
gracias, me resolvio mi problema de formula que tenia en excel,
AL PONER ESTA FORMULA =TEXTO(C13,"mmmm") DA COMO RESULTADO enero sin digitar nada, no quiero que salga nada sin ingresar datos.....alguna idea por favor
> abramsayon -
abramsayon =SI(C1="","",TEXTO(C1,"mmmm"))

utiliza esa formula.
Sos un capo, gracias
12
Gracias
Sencillo, usa la función esnod(), por ejemplo:

=SI(condición,verdadero,falso) da como resultado el #N/A, agrega la función ESNOD, aunque esto implica repetir la formula de nuevo, por ejemplo tendrías que usar otra condicional.

=Si(esnod(función),"",función), lo que quedaría de la siguiente manera al unir:


=Si(esnod(SI(condición,verdadero,falso)),"",SI(condición,verdadero,falso))

NOTA, el "" lo puedes sustituir por un valor o texto.
hola

llevo el dia completo tratando de quitar el resultado !"#valor" que me da en una columna
y no puedo ..... la formula que estoy usando es encontrar() pero no me resulta ni con eserro ni con esnod
estare haciendo algo mal

porf ayudenme
Excelente explicaciòn, muchisimas gracias
gracias . . . si funciono :)
=SIERROR( BUSCAR(C$4:C$37;Productos!B$2:E$35);0)
7
Gracias
En excel, ubica el cursor en la celda donde da el resultado #N/A, presiona F2 y copia la formula (sin el =). Presiona esc en el treclado y ahora persional el =.

En la barra de formulas de excel (que se activa cuando ingresas el =), busca la función SI y selecionala abrirá un asistente pero no le hagas caso todavia, después busca nuevamente en la barra de formula la función ESERROR, esto abrirá otra ventana del asistente. Aqui pega la formula que habiamos copiado en la celda.

Luego te devuelves a la barra de formula y ubica el cursor en SI (esto cambiara el asistente) y en verdadero digiya una -, si es falso vuelve a pegar la formula que habiamos copiado.

Esto validará la formula, si da error dejar un - , si da un valor, pues dejará este valor.
chrisparam, EXCELENTE!!! Gracias.
=if(iserror( Asi se pone en el Inicio y al final de la formula se pone dos )) asia dentro y luego ,"","" y aqui pegas desde despues del error desde donde empiesa el Vlookup y lo vuelves a pegar y donde )) al final y listo ya desaparece
-
tengo una factura y me pone valor null porque no escribo nada en el código, para que desaparezca el valor si no escribo nada en el código como se hace? muchas gracias!!!
jesus_palace
Publicaciones
5
Fecha de inscripción
jueves, 7 de agosto de 2014
Estatus
Miembro
Última intervención
jueves, 7 de agosto de 2014
2 -
pueden ayudarme con esta formula, relaciono dos tablas en el vlookup, pero me sigue apareciendo el mismo error siempre, los datos que busca el VLOOKUP estan en ambas tablas solo que no me deja de marcar el error, ya intente de todo pero nada.
=VLOOKUP('061914'!B5,Sheet1!$C$3:$J$47,4,0)

al copiarlo en otras celdas me marca exactamente el mismo error #N/A
Lleva la tabla a la misma hoja
Publicaciones
5
Fecha de inscripción
jueves, 7 de agosto de 2014
Estatus
Miembro
Última intervención
jueves, 7 de agosto de 2014
2
1
Gracias
pueden ayudarme con esta formula, relaciono dos tablas en el vlookup, pero me sigue apareciendo el mismo error siempre, los datos que busca el VLOOKUP estan en ambas tablas solo que no me deja de marcar el error, ya intente de todo pero nada.
=VLOOKUP('061914'!B5,Sheet1!$C$3:$J$47,4,0)

al copiarlo en otras celdas me marca exactamente el mismo error #N/A
Publicaciones
5
Fecha de inscripción
jueves, 7 de agosto de 2014
Estatus
Miembro
Última intervención
jueves, 7 de agosto de 2014
2
1
Gracias
pueden ayudarme con esta formula, relaciono dos tablas en el vlookup, pero me sigue apareciendo el mismo error siempre, los datos que busca el VLOOKUP estan en ambas tablas solo que no me deja de marcar el error, ya intente de todo pero nada.
=VLOOKUP('061914'!B5,Sheet1!$C$3:$J$47,4,0)

al copiarlo en otras celdas me marca exactamente el mismo error #N/A
jesus_palace
Publicaciones
5
Fecha de inscripción
jueves, 7 de agosto de 2014
Estatus
Miembro
Última intervención
jueves, 7 de agosto de 2014
2 -
ya probé con estó y me dice TRUE
=ISERROR(VLOOKUP('061914'!B11,Sheet1!$C$3:$J$47,4,0))

pero lo que quiero es que arroje el resultado en numeros como formula que es...
Mazzaropi
Publicaciones
1833
Fecha de inscripción
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
286 -
jesus_palace, Buenas tardes.

Inicialmente, la fórmula no tiene errores de ortografía.

Pero si '061914'!B5 no está en la columna C de la hoja de cálculo Sheet1 dentro del rango C3:C47, entonces aparece error.
jesus_palace
Publicaciones
5
Fecha de inscripción
jueves, 7 de agosto de 2014
Estatus
Miembro
Última intervención
jueves, 7 de agosto de 2014
2 -
efectivamente el dato que buscaba en la sheet1 no aparecia ordenado en la hoja
061914 y copiando los datos de uno por uno, por alguna extraña razon se quitan todos los "#N/A"

que ironía, muchas gracias por tu ayuda

saludos
muuuuuuuuuchas grax :)
0
Gracias
hola, alguen me puede decir como hecer la formula para restar dos cantidades y que me de como respuesta la diferencia y otra que si meda un valor negativo esto se convierta en "0" o falso o nada....
0
Gracias
hOLA,

Seria algo asi:

=if((A2-A3)<0;0;(A2-a3))
hola parece facebook
0
Gracias
Exceleten ayuda gracias
gracias por tu aporte