¿Cómo Agrego valor a una letra dentro de una Formula en excel?

Cerrado
siman_Katts
Message postés
2
Date d'inscription
lunes, 13 de julio de 2015
Estatus
Miembro
Última intervención
lunes, 13 de julio de 2015
- 13 jul 2015 a las 03:26
Mazzaropi
Message postés
1963
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
lunes, 25 de abril de 2022
- 14 jul 2015 a las 01:01
Tengo varios valores (notas de curso), por ejemplo C1=12, C2=20, C3=18, C4=03, C5=NA, cada nota tiene un porcentaje de 20% cada uno, como hago para meter en la formula que NA equivale a cero (0) para que no arroje error, sino mas bien, me de la definitiva, por Ejemplo la formula quedaría mas o menos así =((C1*20%)+(C2*20%)+(C3*20%)+(C4*20%)+(C5*20%)), sin embargo a NA debo asignarle una función lógica. Pero, ¿Como lo hago?. Les agradezco de Antemano su orientación
Consulta también:

2 respuestas

Mazzaropi
Message postés
1963
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
lunes, 25 de abril de 2022
508
14 jul 2015 a las 01:01
siman_Katts, Buenas noches.

La mejor manera sería realmente que no había ningún texto mezclado con el campo numérico.
Pero si quieres seguir para poner el código de NA en los campos numéricos, entonces usted puede utilizar la Función SUMA que desprecia los campos textos y sólo suma los números.

Siguiendo su ejemplo, tendríamos:

Antes: =((C1*20%)+(C2*20%)+(C3*20%)+(C4*20%)+(C5*20%))
Ahora: =SUMA(C1:C5)*20%

¿Era esto lo que querías?
Espero haberte ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
0
Mazzaropi
Message postés
1963
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
lunes, 25 de abril de 2022
508
13 jul 2015 a las 12:40
Siman_Katts, Buenos dias.

Si las letras NA significan el valor CERO, entonces ¿por qué no simplemente eliminar esta celda dentro de la fórmula?

NA = 0 Así 0 x 20% = 0

Pero, si C5 puede contener algún valor en un momento posterior, haga lo siguiente:
=(SI (C5 = "NA"; 0; C5) * 20%))

¿Era esto lo que querías?
Espero haberte ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
-1
siman_Katts
Message postés
2
Date d'inscription
lunes, 13 de julio de 2015
Estatus
Miembro
Última intervención
lunes, 13 de julio de 2015

13 jul 2015 a las 22:08
Gracias por la ayuda!

Ahora, ¿Cómo debería ser la función lógica mas adecuada cuando "NA" es aleatoria?, es decir, NA puede estar en cualquier celda. Cual seria la mejor forma de crear la formula para que me la reconozca como cero (0) si aparece en una o varias celdas?
0