Cómo calcular las horas en negativo [Resuelto/Cerrado]

Publicaciones
2
Fecha de inscripción
jueves, 15 de noviembre de 2012
Última intervención
viernes, 21 de diciembre de 2012
-
Hola,
El planteamiento es el siguiente: en un horario de calculo flexible, tendría que calcular día a día los horas que se han trabajado, siendo la jornada laboral de 7 horas y 30 minutos.
Pues algunos días se trabajarán por ejemplo 8 horas y otros día se trabajarán 6 horas y 30 minutos, compensandose la diferencia de un día con otro.

Mi problema es el siguiente, cuando la jornada realizada es superior a las 7 horas y 30 minutos, si me sale una diferencia de minutos en positivo.
Pero si la jornada ha sido inferior a las 7 horas y 30 minutos, no me contempla en negativo los minutos que faltan para completar la jornada.

He hecho lo siguiente
columna E, (formato hora HH:MM) Hora de entrada, por ejemplo 7:20
columna F, (formato hora HH:MM) Hora de salida por ejemplo 14:53
columna H, (formato hora HH:MM) Horas teóricas por ejemplo 7:30 (es la duración de la jornada laboral)

columna I, (formato hora HH:MM) diferencia entre la columna F y la columna E
=SUMA(F5-E5)
columna J, (formato hora HH:MM) Saldo diario =SUMA(I5-H5), en esta celda me salen los munitos de mas que he trabajado, pero si he salido antes de la hora de salida, y he trabajado algunos minutos menos, no me sale en negativo, en su lugar me sale ##########, y no me realiza los calculos

Espero haberme expresado correctamente, ya que mi nivel de usuario es tremendamente básico.

En resumen, lo que pretendo es calcular que cuando trabajo mas de 7 horas y 30 minutos, me salga un saldo positivo de minutos, y cuando trabajo menos de este tiempo me salga un saldo negativo, que luego al sumarlos se compensen unos con otros.

muchas gracias,



Ver más 

5 respuestas

Mejor respuesta
Publicaciones
3
Fecha de inscripción
jueves, 13 de diciembre de 2012
Última intervención
jueves, 20 de diciembre de 2012
45
Gracias
Costó pero lo logré, es dentro de todo sencillo, excel no permite el calculo de horas en negativo, por lo tanto lo que haremos será una función si, en la que pondremos:

=SI(I5< H5;"-"&TEXTO(H5-I5;"hh:mm:ss");TEXTO(I5-H5;"hh:mm:ss"))

Basicamente lo que hace la función es que, si el H es mayor, le resta a ésta el numero menor, y le agrega el signo - adelante al resultado, sin embargo si la H es menor, le resta al numero mayor la H y te da el resutlado sin el signo negativo, parece dificil pero es sencillo

Deja un "Gracias" 45

Unas palabras de agradecimiento nunca están de más. Deja tu comentario

CCM ha ayudado a 18534 usuarios este mes

genial, me has sacado de un apuro
megaryon
Publicaciones
1
Fecha de inscripción
jueves, 21 de septiembre de 2017
Última intervención
jueves, 21 de septiembre de 2017
-
Fue una excelente solución que permite mostrar la información requerida por mis usuarios al realizar los análisis de resultados en la hoja de Excel que estamos trabajando.

Muchas gracias.
muchas gracias, si funciona, aunque en lugar de ; son ,
pero quiza esto solo en mi caso, gracias por ayudar
Excelente respuesta!!! Muchas gracias!!!
19
Gracias
Hay una opción más fácil:
a) Poner el formato de Hora nombrado como 37:30:35
b) En Opciones > Avanzadas > Al calcular este libro > Hacer clic en "Usar sistema de fechas 1904
-
El problema que me ha pasado a mi es que tenía fechas de otros años y me ha cambiado el año de cada fila.
-
Yo quería dar un paso más...Quiero hacer resta de horas, y que el resultado sea mayor a -24:00:00 y que se pongan de color rojo. Ahora lo hago en Formato celda -> Hora->37:00:00, pero me sale en NEGRO. Como lo puedo hacer?

Si lo hago, en Personalizada, h:mm:ss;[Rojo]-h:mm:ss, cuando pasa de -24:00:00 me contabiliza días, y si fueran -25h, pone -1:00:00. Por favor contestarme también por mail ya que no estoy registrado. ***@***
5
Gracias
Podéis probar en esta entrada de Microsoft:

https://support.microsoft.com/es-es/kb/182247

Aún más sencillo.

Un saludo.
Publicaciones
2
Fecha de inscripción
jueves, 15 de noviembre de 2012
Última intervención
viernes, 21 de diciembre de 2012
1
Gracias
Muchisimas gracias ZODILOOD, voy a probarlo y seguro que me soluciona el tema.
Te repito las gracias
Un saludo
-1
Gracias
Excelente respuesta ZOODILOC me salvste si funciona gracias