Como multiplicar dos celdas a partir de una condición

[Cerrado]
Denunciar
Message postés
1
Date d'inscription
jueves, 11 de abril de 2013
Estatus
Miembro
Última intervención
jueves, 11 de abril de 2013
-
Message postés
1
Date d'inscription
martes, 24 de enero de 2017
Estatus
Miembro
Última intervención
martes, 24 de enero de 2017
-
Buenas Necesito que alguien me ayude con una duda de excel. Tengo una tabla en donde en la celda F5 manualmente escribo tres opciones (A, B 0 C) , esas opciones las tengo mas abajo con su respectivo peso en las celdas D90, D91 Y D92, en la celda G5 tengo la cantidad de material, NECESITO que la celda H5 me multiplique el peso de acuerdo a la opción que escogí en la celda F5 * G5 que es la cantidad.

Por ejemplo:
F5= A
G5=30
H5= 30*(si F5 Dice A me multiplique por D90, pero si F5 dice B me multiplique por D91, pero si F5 dice C me multiplique por D92 y si no es igual a ninguna multiplique por CERO)

2 respuestas

Message postés
15
Date d'inscription
martes, 14 de junio de 2011
Estatus
Miembro
Última intervención
miércoles, 29 de mayo de 2013
127
ESTA ES LA FORMULA:
=SI(F5="A",30*D90,(SI(F5="B",30*D91,(SI(F5="C",30*D92,30*0)))))
33
Gracias

Unas palabras de agradecimiento nunca están de más. Deja tu comentario

CCM 12872 usuarios nos han dicho gracias este mes

Message postés
1
Date d'inscription
martes, 24 de enero de 2017
Estatus
Miembro
Última intervención
martes, 24 de enero de 2017

Creo que definiendo una funcion de excel es mas facil de controlar, supongamos que vamos a hacer la funcion para las celdas A1 hasta la A13, copiamos esta funcion en el editor de visual basic y luego le indicamos al insertar la funcion personalizada cuales son las celdas

Function Mul(A1, A2, A3, A4, A5, A6, A7, A8, A9, A10, A11, A12, A13 As Single) As Single
Dim Valor As Boolean

Valor = True
If A1 = 0 Then A1 = 1 Else Valor = False
If A2 = 0 Then A2 = 1 Else Valor = False
If A3 = 0 Then A3 = 1 Else Valor = False
If A4 = 0 Then A4 = 1 Else Valor = False
If A5 = 0 Then A5 = 1 Else Valor = False
If A6 = 0 Then A6 = 1 Else Valor = False
If A7 = 0 Then A7 = 1 Else Valor = False
If A8 = 0 Then A8 = 1 Else Valor = False
If A9 = 0 Then A9 = 1 Else Valor = False
If A10 = 0 Then A10 = 1 Else Valor = False
If A11 = 0 Then A11 = 1 Else Valor = False
If A12 = 0 Then A12 = 1 Else Valor = False
If A13 = 0 Then A13 = 1 Else Valor = False
If Valor = False Then
Mul = A1 * A2 * A3 * A4 * A5 * A6 * A7 * A8 * A9 * A10 * A11 * A12 * A13
Else
Mul = 0
End If
End Function

Si son menos valores editan la funcion