Convertir un texto en un valor numerico en excel [Resuelto/Cerrado]

Denunciar
Message postés
1
Date d'inscription
domingo, 23 de febrero de 2014
Estatus
Miembro
Última intervención
domingo, 23 de febrero de 2014
-
 Mariangel -
Buen día, quisiera saber si puedo reemplazar o asignar un valor a un texto, concretamente en este ejemplo a una letra para calcular luego un resultado. Por ejemplo una columna que posee un nombre y en las subsiguientes 31 columnas (días) le asigno una letra "P" (Presente) o "A" (Ausente) o "T" (Tardanza) y a los fines de realizar cálculos de asistencia, le asigno a "P" un valor de "1" a "A" un valor de "0" y a "T" un valor de "0.5" y luego poder realizar los cálculos pertinentes de asistencia.
Agradeceré mucho vuestra ayuda!!
Saludos a Todos

1 respuesta

Message postés
1833
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
291
Pollostep, Buenas Noches.

A1 = Nombre
Supongamos que los datos están en B1 a AF1.
B1 --> K1 = P
L1 --> U1 = T
V1 --> AF1 = A
Este es sólo un ejemplo.

Hacer esto:
AH1 --> = CONTAR.SI(B1:AF1;"P")
AI1 --> = CONTAR.SI(B1:AF1;"T")
AJ1 --> = CONTAR.SI(B1:AF1;"A")

Con esto se obtiene el total de cada letra en el período.

Cómo quieres hacer un cálculo con el total a sólo hacer:
AH1 --> = CONTAR.SI(B1:AF1;"P")*1
AI1 --> = CONTAR.SI(B1:AF1;"T")*0,5
AJ1 --> = CONTAR.SI(B1:AF1;"A")*0 ? ? ?

¿Es esto lo que quieres?
Espero haber ayudado.
2
Gracias

Unas palabras de agradecimiento nunca están de más. Deja tu comentario

CCM 42667 usuarios nos han dicho gracias este mes

Marifranck
Message postés
1
Date d'inscription
miércoles, 30 de marzo de 2016
Estatus
Miembro
Última intervención
miércoles, 30 de marzo de 2016

hola Mazzaropi podrías ayudarme, es para tabular una encuesta, tengo columnas que representan valores desde 1 a 4 es decir 5 entrevistados en donde cada uno tiene la opcion de calificar del 1 al 4, esta calificacion está en el encabezado de cada columna, es decir: Sujeto 1, Sujeto 2, Sujeto 3 ...Sujeto 5, Opcion de calificación 4, 3, 2 ,1 en las filas esta la letra "X" q representa la calificación de cada sujeto, esta "x" estan valoradas, en 4 , 3, 2, 1 dependiendo en que columna se haya colocado, ejemplo: Sujeto 1 Columa A1 = 4 B1=3 C1= 2 D1=1 este sujeto 1 calificó marcando en la fila C1 con una x, esta X tiene el valor de "2" puesto que el sujeto 1 marcó esa calificacion y asi sucesivamente van calificando los 4 sujetos restantes, al final tengo que totalizar, sumar la calificación de todos los sujetos, y en otra columna tengo que promediar: es decir si todos calificaron 4 el total es 20(porque son 5 sujetos) y hay 4 preguntas calificadas, por lo tanto la suma de las respuesta debo de promediarla para el total de preguntas que son 3 que cada sujeto calificó. Qué fòrmula aplicaría, Agradezco tu gentil respuesta!
Me sirvió a la perfección.. Gracias!