Horas nocturnas en excel

[Cerrado]
Denunciar
-
 Guillermo -
Hola,
NECESITO AYUDA CON LAS HORAS DE EXCEL,
personal f entra hora enrt fecha sal hora Sali duracion noches
VICENTE 05-ago-09 11:00 05-ago-09 15:00 4:00 0:00
VICENTE 10-ago-09 23:23 11-ago-09 6:15 6:52 6:52
VICENTE 14-ago-09 8:15 14-ago-09 14:30 6:15 0:00
VICENTE 03-ago-09 7:45 03-ago-09 15:50 8:05 0:00
PEDRO 03-ago-09 7:45 03-ago-09 15:50 8:05 0:00
PEDRO 05-ago-09 11:00 05-ago-09 15:00 4:00 0:00
LUIS 10-ago-09 23:23 11-ago-09 6:15 6:52 6:52
MANOLO 10-ago-09 23:23 11-ago-09 6:15 6:52 6:52
PEDRO 10-ago-09 23:23 11-ago-09 6:15 6:52 6:52
LUIS 06-ago-09 7:05 06-ago-09 15:00 7:55 0:00
65:48 2235:28

COMO PODEIS VER EN EL TOTAL DE HORAS CUANDO CUENTA NOCHES ME DA UN RESULTADO EQUIVOCADO, ALGUIEN ME PUEDE AYUDAR, POR FAVOR.

8 respuestas

esa parte de la formula es para el caso de que se comienze el dia anterior y me cuente las horas que ha trabajado.
6
Gracias

Unas palabras de agradecimiento nunca están de más. Deja tu comentario

CCM 12872 usuarios nos han dicho gracias este mes

Muchas gracias Amuro, la solución final es esta =SI(D2>F2;(F2-D2)+(F2<D2);0), tuve que quitar el *24 y el +1, asi me funciona perfectamente y no me incrementa las horas totales del mes.
Message postés
5002
Date d'inscription
lunes, 3 de noviembre de 2008
Estatus
Miembro
Última intervención
sábado, 9 de abril de 2011
5.564
Simplemente sumale 24 horas al calculo cuando pones ha hora final
o sea (Hora final + 24:00:00)-Hora inicial
el problema no es en el dia a dia, sino en el sumatorio de las horas de la última columna, en la formula diaria aplico lo siguiente
=SI(C2>E2;(E2-C2)+(E2<C2)*24;0)
y al final me da un resultado de 2235:28 cuando debiera decir 27:28
gracias de todos modos y sigo esperando.
Message postés
5002
Date d'inscription
lunes, 3 de noviembre de 2008
Estatus
Miembro
Última intervención
sábado, 9 de abril de 2011
5.564 > endoscop
Hummm tenes un (E2<C2)*24 en esa formula para que se lo pusiste?
=SI(C5>D5;(D5-C5)+(D5<C5)*12;SI(D5>C5;(D5-C5)+(C5<D5)*12;0))
Este es el Resultado de el Calculo de Horas Nocturnas y a la vez Diurnas ó Vespertinas
Message postés
5002
Date d'inscription
lunes, 3 de noviembre de 2008
Estatus
Miembro
Última intervención
sábado, 9 de abril de 2011
5.564
Ya le encontre el sentido!

te acordas cuando pusimos =E2+24 hay que poner =E2+1/24 así incrementa 1 hora por ende hay que hacer =E2+1

asi le incrementa 24 hs


la formula total seria =SI(C2>E2;(E2-C2)+1;0)
el +1 es por que ya de por si C2 es mas grande que E2
Message postés
5002
Date d'inscription
lunes, 3 de noviembre de 2008
Estatus
Miembro
Última intervención
sábado, 9 de abril de 2011
5.564
Perfecto! viste que en conjunto se pueden hacer las cosas?
Message postés
5002
Date d'inscription
lunes, 3 de noviembre de 2008
Estatus
Miembro
Última intervención
sábado, 9 de abril de 2011
5.564
Ah disculpá si es true devuelve 1 y lo multiplica * 24 ta bien

pero falta la otra parte =if(C2>E2;(E2-C2)+(E2<C2)*24;E2-C2)


Pero fijate, si pones: =E2+24 vas a ver que te pone un numero muy alto no le encuentro el sentido
muchisimas gracias por tu interes amuro pero no es la solucion.
en esa formula =SI(C2>E2;(E2-C2)+(E2<C2)*24;0) esta diseñada para una columna que solo cuenta las horas nocturnas, no las diurnas.
a ver si consigo explicarme bien.
en A tenemos el nombre de la persona, en B la fecha de inicio, en C la hora de inicio de la jornada, en D la fecha del final del trabajo, en E la hora final del trabajo, en F nos dice cuantas horas trabajo en la jornada, en G nos dice cuantas horas trabajo de noche (coincide con la columna F si el horario fué nocturno).
todo esto es correcto con las formulas conocidas, el problema le tenemos cuando queremos sumar las horas, en F12 y en G12 hago un =SUMA(F2:F11) y =SUMA(G2:G11) y el resultado de G12 es el que no me da las horas correctamente.

muchisimas gracias por ocuparte de mi.
SOLO TIENES QUE CAMBIAR LAS CELDAS DE LA FORMULA.
2,00 5,75
22:00 05:45

22:00 06:00
24:00 00:00

A1=SI(AK18>=AK20;(AK21-AK18);0)*24/1
A2=SI(AM18<=AM20;AM18;AM20)*24/1