Reproducir ultima celda de una columna no tenga 0 [Resuelto/Cerrado]

- - Última respuesta: seferrando
Publicaciones
2
Fecha de inscripción
miércoles, 28 de marzo de 2018
Estatus
Miembro
Última intervención
viernes, 30 de marzo de 2018
- 30 mar 2018 a las 18:17
Hola,
Estoy buscando una formula que reproduzca en una celda la ultima celda de un rango de una columna que no sea 0, es decir, que excluya las celdas con 0.
Ejemplo:
A B C
1
2 349
3 180
4 0
5 74
6 0
7

Reproducir en la celda C1 la cifra que esta en la ultima celda de la columna A en el rango de A2 a A6.

Gracias.
Seba



Ver más 

2 respuestas

Publicaciones
1833
Fecha de inscripción
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
204
0
Gracias
Seba, Buenas noches.

Pruebe a usar esta fórmula:
 =SI.ERROR(BUSCAR(2;1/(A2:A6>0);A2:A6);" ")

Atención: Compruebe cuál es la señal de separación de argumento en la función en su versión de Excel.
Es punto y coma ( ; ) o sólo coma ( , )?
Adapte el separador a su realidad.

¿Era eso lo que quería?
Espero haber ayudado.
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão
seferrando
Publicaciones
2
Fecha de inscripción
miércoles, 28 de marzo de 2018
Estatus
Miembro
Última intervención
viernes, 30 de marzo de 2018
-
Hola Marcilio,
Es exactamente lo que necesitaba. Gracias.
Lo unico es que la funcion SI.ERROR en mi version de excel se escribe SIERROR.
Me podrias traducir/explicar lo que significa la formula para aprender.

Muchas gracias,
Seba
Publicaciones
1833
Fecha de inscripción
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
204
0
Gracias
seferrando, Buenas noches.

"...Me podrias traducir/explicar lo que significa la formula para aprender...."

Devuelve el valor especificado si una fórmula se evalúa como un error; de lo contrario, devuelve el resultado de la fórmula.
Use la función SIERROR para interceptar y controlar errores en una fórmula.

Siga este vínculo de soporte técnico de Microsoft y encuentre todo sobre la función SIERROR.
https://support.office.com/es-es/article/si-error-funci%c3%b3n-si-error-c526fd07-caeb-47b8-8bb6-63f3e417f611?omkt=es-HN&ui=es-ES&rs=es-HN&ad=HN

También utiliza el Help del propio Excel para entender la forma de uso de la función SIERROR y aún ver ejemplos.
Es muy buena la explicación.

Espero haber ayudado.
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão
seferrando
Publicaciones
2
Fecha de inscripción
miércoles, 28 de marzo de 2018
Estatus
Miembro
Última intervención
viernes, 30 de marzo de 2018
-
Muchas Graicas,
Marcilio