Error en resta de celdas [Resuelto/Cerrado]

Publicaciones
6
Fecha de inscripción
domingo, 15 de enero de 2017
Última intervención
lunes, 16 de enero de 2017
-
Hola,
Celda A1=0,82
Celda A2=0,83
Celda A3=SI(A2-A1=0,01;"SI";"NO")
El resultado de A3 es "NO"
No veo el error. Si en vez de 0,82 y 0,83 uso cualquier otro par de valores cuya resta dé 0,1, funciona y el resultado de A3 da "SI".
No lo entiendo. ¿Un bug de Excel?
Aprecio cualquier comentario.


Ver más 

5 respuestas

Publicaciones
1834
Fecha de inscripción
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
0
Gracias
alorana, Buenos dias.

El resultado de A3 no es correcta.

¿Estas seguro que los valores A1 y A2 son exactamente lo que ves?

Tomar una prueba.
Aumentará a 5 decimales valores A1 y A2.
Los valores son exactamente 0,82 y 0,83?

Espero haber ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
Publicaciones
6
Fecha de inscripción
domingo, 15 de enero de 2017
Última intervención
lunes, 16 de enero de 2017
0
Gracias
Pruébalo en una hoja en blanco:
Publicaciones
6
Fecha de inscripción
domingo, 15 de enero de 2017
Última intervención
lunes, 16 de enero de 2017
0
Gracias
Pasa con algunos valores. 0.83 y 0.82 son dos de ellos.
0,15 y 0.14 son otros dos.
Publicaciones
1834
Fecha de inscripción
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
0
Gracias
alorana, buenas tardes.

"...No lo entiendo. ¿Un bug de Excel? ..."
Hice una prueba y encontré varias de estas diferencias.
Creo que es un problema de redondeo automático de Excel.

Si quieres ver mi prueba:
https://www.sendspace.com/file/lfz1cq

Para evitar este error utilizar la Función: Redondear.

Con un máximo de 15 cifras decimales se resuelve el problema .

Entonces: =Redondear(A1-A2; 15) va a resolver este extraño diferencia.

Realmente espero haber ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
Publicaciones
6
Fecha de inscripción
domingo, 15 de enero de 2017
Última intervención
lunes, 16 de enero de 2017
0
Gracias
Gracias! Pero no deja de ser curioso... Microsoft debería saberlo y corregirlo.
Muchas gracias.