Función Si, para devolución de valores

Resuelto/Cerrado
msolar Message postés 3 Date d'inscription jueves, 1 de octubre de 2015 Estatus Miembro Última intervención viernes, 2 de octubre de 2015 - 1 oct 2015 a las 19:09
msolar Message postés 3 Date d'inscription jueves, 1 de octubre de 2015 Estatus Miembro Última intervención viernes, 2 de octubre de 2015 - 2 oct 2015 a las 19:56
Hola Todos

Deseo hacer una validación de 4 variantes (números), y dependiendo de su condición asignar una devolución de valor en tres opciones.
  • Si A1 es igual a 0% o igual a 100 "operación"
  • Si A1 es mayor que cero pero menor que 100 "construcción"
  • Si A2 es mayor 0 "operación"


El que se me complica es validar
  • Si A1 está entre 0 y 100 y A2 es mayor que 0 devolver el texto "operación/construcción"
  • Al final de todas estas variantes debo obtener solo una respuesta de tres posibles


1. Construcción
2. Construcción/Operación
3. Operación

Necesito que esta validación solo sea en una celda.
Gracias

1 respuesta

Mazzaropi Message postés 1978 Date d'inscription lunes, 16 de agosto de 2010 Estatus Contribuidor Última intervención viernes, 18 de noviembre de 2022 523
2 oct 2015 a las 18:43
msolar, Buenas tardes.

Trate de usar esta fórmula:

=SI(O(A1=0;A1=100;A2>0);"Operación";SI(Y(A1>0;A1<100);SI(A2>0;"Operación/Construcción";"Construcción");""))

Eso es lo que querías?
Espero haber ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
1
msolar Message postés 3 Date d'inscription jueves, 1 de octubre de 2015 Estatus Miembro Última intervención viernes, 2 de octubre de 2015
Modificado por msolar el 2/10/2015, 20:10
Hola. Mazzaropi

Este aporte me ha hecho el día, llevaba probando varias formulas lo intente por separado y al final obtener el resultado.

previamente hay una validación que me sumaba las variables y a partir de ese resultado aplicaba la sig formula.


=SI(A5=3,"CONSTRUCCIÓN",SI(A6=3,"OPERACIÓN","OPERACIÓN/CONSTRUCCIÓN"))

con lo que tu me envías logre acomodarla de la siguiente forma y esta fue la definitiva.

=SI(O(A1=100),"Operación",SI(Y(A1>0,A1<100),SI(A2>0,"Operación/Construcción","Construcción"),""))

Muchísimas Gracias
0