Función Si, para devolución de valores [Resuelto/Cerrado]

msolar 3 Publicaciones jueves, 1 de octubre de 2015Fecha de inscripción viernes, 2 de octubre de 2015 Última intervención - 1 oct 2015 a las 19:09 - Última respuesta: msolar 3 Publicaciones jueves, 1 de octubre de 2015Fecha de inscripción viernes, 2 de octubre de 2015 Última intervención
- 2 oct 2015 a las 19:56
Hola Todos

Deseo hacer una validación de 4 variantes (números), y dependiendo de su condición asignar una devolución de valor en tres opciones.
  • Si A1 es igual a 0% o igual a 100 "operación"
  • Si A1 es mayor que cero pero menor que 100 "construcción"
  • Si A2 es mayor 0 "operación"


El que se me complica es validar
  • Si A1 está entre 0 y 100 y A2 es mayor que 0 devolver el texto "operación/construcción"
  • Al final de todas estas variantes debo obtener solo una respuesta de tres posibles


1. Construcción
2. Construcción/Operación
3. Operación

Necesito que esta validación solo sea en una celda.
Gracias
Ver más 

2 respuestas

Mejor respuesta
Mazzaropi 1834 Publicaciones lunes, 16 de agosto de 2010Fecha de inscripciónContribuidorEstatus miércoles, 30 de mayo de 2018 Última intervención - 2 oct 2015 a las 18:43
1
Gracias
msolar, Buenas tardes.

Trate de usar esta fórmula:

=SI(O(A1=0;A1=100;A2>0);"Operación";SI(Y(A1>0;A1<100);SI(A2>0;"Operación/Construcción";"Construcción");""))

Eso es lo que querías?
Espero haber ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão

Gracias, Mazzaropi 1

¿Algo que decir? Deja tu comentario

CCM ha ayudado a 23119 usuarios este mes

msolar 3 Publicaciones jueves, 1 de octubre de 2015Fecha de inscripción viernes, 2 de octubre de 2015 Última intervención - 2 oct 2015 a las 19:56
Hola. Mazzaropi

Este aporte me ha hecho el día, llevaba probando varias formulas lo intente por separado y al final obtener el resultado.

previamente hay una validación que me sumaba las variables y a partir de ese resultado aplicaba la sig formula.


=SI(A5=3,"CONSTRUCCIÓN",SI(A6=3,"OPERACIÓN","OPERACIÓN/CONSTRUCCIÓN"))

con lo que tu me envías logre acomodarla de la siguiente forma y esta fue la definitiva.

=SI(O(A1=100),"Operación",SI(Y(A1>0,A1<100),SI(A2>0,"Operación/Construcción","Construcción"),""))

Muchísimas Gracias