Función Si, para devolución de valores [Resuelto/Cerrado]

Denunciar
Message postés
3
Date d'inscription
jueves, 1 de octubre de 2015
Estatus
Miembro
Última intervención
viernes, 2 de octubre de 2015
-
Message postés
3
Date d'inscription
jueves, 1 de octubre de 2015
Estatus
Miembro
Última intervención
viernes, 2 de octubre de 2015
-
Hola Todos

Deseo hacer una validación de 4 variantes (números), y dependiendo de su condición asignar una devolución de valor en tres opciones.
  • Si A1 es igual a 0% o igual a 100 "operación"
  • Si A1 es mayor que cero pero menor que 100 "construcción"
  • Si A2 es mayor 0 "operación"


El que se me complica es validar
  • Si A1 está entre 0 y 100 y A2 es mayor que 0 devolver el texto "operación/construcción"
  • Al final de todas estas variantes debo obtener solo una respuesta de tres posibles


1. Construcción
2. Construcción/Operación
3. Operación

Necesito que esta validación solo sea en una celda.
Gracias

1 respuesta

Message postés
1833
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 16 de septiembre de 2020
359
msolar, Buenas tardes.

Trate de usar esta fórmula:

=SI(O(A1=0;A1=100;A2>0);"Operación";SI(Y(A1>0;A1<100);SI(A2>0;"Operación/Construcción";"Construcción");""))

Eso es lo que querías?
Espero haber ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
1
Gracias

Unas palabras de agradecimiento nunca están de más. Deja tu comentario

CCM 35712 usuarios nos han dicho gracias este mes

Message postés
3
Date d'inscription
jueves, 1 de octubre de 2015
Estatus
Miembro
Última intervención
viernes, 2 de octubre de 2015

Hola. Mazzaropi

Este aporte me ha hecho el día, llevaba probando varias formulas lo intente por separado y al final obtener el resultado.

previamente hay una validación que me sumaba las variables y a partir de ese resultado aplicaba la sig formula.


=SI(A5=3,"CONSTRUCCIÓN",SI(A6=3,"OPERACIÓN","OPERACIÓN/CONSTRUCCIÓN"))

con lo que tu me envías logre acomodarla de la siguiente forma y esta fue la definitiva.

=SI(O(A1=100),"Operación",SI(Y(A1>0,A1<100),SI(A2>0,"Operación/Construcción","Construcción"),""))

Muchísimas Gracias