Porcentajes con "sumar.si" o "contar.si"

Denunciar
Message postés
1
Date d'inscription
domingo, 8 de marzo de 2020
Estatus
Miembro
Última intervención
domingo, 8 de marzo de 2020
-
Message postés
25
Date d'inscription
viernes, 10 de abril de 2020
Estatus
Miembro
Última intervención
jueves, 2 de julio de 2020
-
¡Hola! Tengo una duda. Soy novata en Excel. ¿Me podéis ayudar?, ¿cómo se calcula un porcentaje con las funciones de "sumar.si" o "contar.si"?
En una tabla de Excel quiero sacar:
¿Qué porcentaje de alumnos no se presentaron (NP) al examen de Lógica con respecto al total de aspirantes?
De la casilla E7 a la E42 tengo AP (Aprobado)s, NA (No Aprobado)s y NP (No Presentado)s. En total 36 personas.
Para calcular los NPs he puesto esta fórmula:
=CONTAR.SI(E7:E42;"NP") y me sale 14.
Si tuviera que calcular la fórmula a mano haría este cálculo: 14*100/36=39%
¿Cómo lo pongo en una fórmula?
En otra casilla marco la celda (G24) dónde me sale 14 así:
=G24*100/SUMA(E7:E42)
Y me da error.
Un saludo. A la espera de vuestra respuesta,
Niki

2 respuestas

Message postés
2
Date d'inscription
domingo, 19 de abril de 2020
Estatus
Miembro
Última intervención
domingo, 19 de abril de 2020
1
Hola PMantaras tienes que poner =CONTAR.SI(E7:E42;"NP")*100/36. En esta web -> https://cursos.gold/cursos-de-excel-online-gratis/ encontrarás algunos cursos online gratis que te pueden ser de utilidad. Un saludo!

Si quieres que 36 sea el número de celdas con datos entonces =CONTAR.SI(E7:E42;"NP")*100/CONTARA(E7:E42)

También puedes poner CONTARA(E7:E16000) por ejemplo, si no tienes datos debajo para que te coja una mayor cantidad de celdas y no tengas que estar cambiándolo cada vez que añadas un registro.

1
Gracias

¡Estamos felices de haberte ayudado! ¿Te hemos sido de ayuda? ¡Déjanos un comentario! Evalúa a CCM

CCM 32891 usuarios nos han dicho gracias este mes

Message postés
25
Date d'inscription
viernes, 10 de abril de 2020
Estatus
Miembro
Última intervención
jueves, 2 de julio de 2020
4
Hola abad3d. La fórmula que pones es correcta pero no lo es menos que si aplicas formato % a la celda, no necesitas multiplicar por 100 porque va implicito en el formato, que era lo que pretendía explicar en la respuesta.
Respecto a ese CONTARA que le comentas, no soy muy amigo de recomendar ese tipo de fórmulas porque acaban ralentizando ls cálculos de las hojas de forma innecesaria, en todo caso convertiría el rango a tabla para simplificar esas operaciones.

Un saludo
Message postés
25
Date d'inscription
viernes, 10 de abril de 2020
Estatus
Miembro
Última intervención
jueves, 2 de julio de 2020
4
Hola, en la celda que haces el contar.si añades la división por el total de alumnos, le pones formato porcentaje (%) y listo.

Un saludo