Cómo restar fechas en Excel [Resuelto]

decarlos 1 Publicaciones viernes, 28 de julio de 2017Fecha de inscripción viernes, 28 de julio de 2017 Última intervención - 28 jul 2017 a las 22:10 - Última respuesta: Mazzaropi 1834 Publicaciones lunes, 16 de agosto de 2010Fecha de inscripciónContribuidorEstatus miércoles, 30 de mayo de 2018 Última intervención
- 30 jul 2017 a las 13:57
El problema es el siguiente:

se requiere una fórmula de excel para restar fecha anterior (a) de fecha reciente (b) con tres condiciones dadas en tres casos:
1er caso:
si fecha reciente es menor que fecha anterior, el resultado sea "fecha incorrecta";
por ej: fecha (a) 14/02/18 fecha (b) 14/02/17

2do caso:
si ambas fechas iguales, el resultado sea "1";
por ej: fecha (a) 14/02/17 fecha (b) 14/02/17

3er caso:
si fecha reciente es mayor que fecha anterior, el resultado sea la resta simple de las fechas.

por ej: fecha (a) 10/02/17 fecha (b) 14/02/17

Tengo las fórmulas por separado, funcionando.

Cual seria la fórmula para anidar las tres anteriores en una sola? Muchas gracias!
Ver más 

Tu respuesta

3 respuestas

Mazzaropi 1834 Publicaciones lunes, 16 de agosto de 2010Fecha de inscripciónContribuidorEstatus miércoles, 30 de mayo de 2018 Última intervención - 30 jul 2017 a las 13:57
0
Gracias
decarlos, buenos dias.

Gracias por el feedback.
Feliz en poder ayudarte
--
Belo Horizonte, Brasil.
Marcílio Lobão
Comenta la respuesta de Mazzaropi
Mazzaropi 1834 Publicaciones lunes, 16 de agosto de 2010Fecha de inscripciónContribuidorEstatus miércoles, 30 de mayo de 2018 Última intervención - 29 jul 2017 a las 15:57
-1
Gracias
decarlos, Buenos dias.

Como usted ya tiene las tres fórmulas listas y funcionando individualmente, basta combinarlas así:

Supongamos:

A1 --> 10/02/2017
B1 --> 14/02/2017

=SI(B1<A1; "fecha incorrecta"; SI(B1=A1; 1; B1-A1))

¿Eso es lo que quieres?
Espero haber ayudado.
Listo! muchas gracias. Obrigado!
Comenta la respuesta de Mazzaropi