Formulas con condicionales

[Cerrado]
Denunciar
Message postés
1
Date d'inscription
lunes, 22 de agosto de 2016
Estatus
Miembro
Última intervención
lunes, 22 de agosto de 2016
-
Message postés
1943
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 22 de septiembre de 2021
-
Buenas tardes:

Estoy intentando construir una formula que me permita evaluar una celda (M) y que si (M) es igual a "X" se evalúen ciertos datos y se proceda a realizar la operación, pero si (M) = "Y" evalue otros datos y realice la operación y por último si (M) = "Y" evalue otros datos y realice la operación, ya realice el planteamiento de la formula y cuando la valido indivudualmente me da el resultadopero cuado las uno me reporta un falso

así es cuando las uno:
=SI(M416="AI";SI($I416<>0;$I416/$AB$6;SI($K416<>0;$K416/$AD$6;SI($J416<>0;$J416/$AC$6;SI(O(M416="GI");SI($I416<>0;$I416/$Y$6;SI($K416<>0;$K416/$AA$6;SI($J416<>0;$J416/$Z$6;SI(O(M416="D");SI($I416<>0;$I416/$AE$6;SI($K416<>0;$K416/$AG$6;SI($L416<>0;$L416/$AH$6;SI($J416<>0;$J416/$AF$6)))))))))))))

y así cuando las trabajo individualmente para cada parámetro:

=SI(F70="AI";SI($G70<>0;$G70/$AA$11;SI($H70<>0;$H70/$Y$11;SI($I68<>0;$I70/$Z$11)))), esta es una condición,
=SI(F70="D";SI($G70<>0;$G70/$X$11;SI($H70<>0;$H70/$V$11;SI($I70<>0;$I70/$W$11))))), esta es otra y
=SI(F70="D";SI($G70<>0;$G70/$AD$11;SI($H70<>0;$H70/$AB$11;SI($J70<>0;$J70/$AE$11;SI($I70<>0;$I70/$AC$11)))))

Alguien podría ayudarme para saber que error cometí y poder corregirlo. Para mayor claridad adjunto imágenes del procedimiento realizado.

Espero haber sido lo suficientemente clara.

De antemano agradezco su colaboración A quién me pueda ayudar nuevamente Graciasssss

Francy Dayannaa

1 respuesta

Message postés
1943
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 22 de septiembre de 2021
474
Francy, Buenas noches.

Su explicación es muy confuso.

El hecho de que aparezca la palabra "falso" es porque falta el último argumento de la última función SI.

Basta hacer:
Antes: $ J416 / $ AF $ 6)))))))))))))
Ahora: $ J416 / AF $ $ 6;"")))))))))))))

La fórmula tiene un problema de lógica que no va a funcionar.
Las dos últimas condiciones son idénticas, pero abundan diferentes operaciones que hay que hacer al mismo tiempo?
Esto no se puede hacer.

b) = SI (F70 = "D"; SI ($G70 <> 0; $G70 / $X$11; .......

c) = SI (F70 = "D"; SI ($G70 <> 0; $G70 / $AD$11;

Esta parte no era posible de entender.