Error al restar horas y fechas en Excel [Resuelto/Cerrado]

Publicaciones
7
Fecha de inscripción
jueves, 19 de septiembre de 2013
Estatus
Miembro
Última intervención
lunes, 17 de febrero de 2014
-
Buenos días, tengo:
Columna A esta fórmula :=SI(FILA($A1)>'T. Conexión'!$O$3;"";INDICE('T. Conexión'!$K$3:$M$200;COINCIDIR(FILA($A1);'T. Conexión'!$N$3:$N$10001;0);1)).
Columna B esta otra: =SI(FILA($A1)>'T. Conexión'!$O$3;"";INDICE('T. Conexión'!$K$3:$M$200;COINCIDIR(FILA($A1);'T. Conexión'!$P$3:$P$10001;0);2)).

La cuestión es que estas formulas me devuelven una fecha con la hora (19/09/2013 8:00 - columna A y 19-09-2013 - columna B) y lo que quiero es restar estas fechas con estas horas con la fórmula =B1-A1 y me funciona pero donde no hay datos me sale el error #valor! y me gustaría que si no hay datos no saliera este error.

Muchas gracias por adelantado.

Saludos
Ver más 

5 respuestas

Mejor respuesta
Publicaciones
1833
Fecha de inscripción
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
250
3
Gracias
Buenos dias isabelyoplin.

Esto es fácil de resolver.
Utilice =SI(A1 = "";""; la fórmula de aquí )

Si necesita más ayuda, por favor pregunte.

¿Sigues trabajando en esa hoja de cálculo que me ayudó a resolver el problema de las horas trabajadas?

Deja un "Gracias" 3

Unas palabras de agradecimiento nunca están de más. Deja tu comentario

CCM 34041 usuarios nos han dicho gracias este mes

0
Gracias
Hola Mazzaropi, si todavía estoy con la misma hoja de cálculo con la que me ayudaste, por cierto esta formula que me has dado me ha servido de ayuda para un par de cosas mas, muchas gracias, solo me quedan un par de cosillas que se me escapan, una es sencilla pero no doy con la solución, el caso es que en una hoja pego estos datos:

Agente Login Atendidas M.Convers M.Codificación
LUCIA LOPEZ GARCIA 1113 935 0:01:10 0:00:03
ANTONIA TRIGUERO MAS 1111 603 0:01:20 0:00:02
RAQUEL DIAZ MONTERO 1112 476 0:01:08 0:00:02

y en la hoja del informe:

Agente Login Atendidas M. Conversación M. Codificación ANTONIA TRIGUERO MAS 1111 RAQUEL DIAZ MONTERO 1112 LUCIA LOPEZ GARCIA 1113

la fórmula que he realizado para buscar los datos es la de =BUSCARV(E477;'Producción Agente'!B3:F5;3) y me sale correcto en 2 filas meno en 1, he probado con el formato de celdas, a poner los nombres en el mismo orden ...etc. pero no me devuelve los datos que le corresponden me devuelve los mismos datos de otro agente.

Sabes el motivo?, me podrías ayudar una vez mas por favor?.

La otra es mas complicada

En una hoja tengo el calendario laboral y en la hoja del informe un espacio donde pretendo que si pongo p.e. julio en una celda me devuelva todo el mes de julio con sus colores, no se si me podrás ayudar con esto aun así muchas gracias por intentarlo.

Gracias
Publicaciones
1833
Fecha de inscripción
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
250
0
Gracias
Buenos dias, Isabelyoplin.

a) La fórmula necesita ser ajustado.
a.1) Utilizar todos los argumentos de la fórmula. Usted debe poner el último argumento de 0 (cero).
a.2) Cómo va a poner la fórmula en la primera celda del rango y se arrastra hacia abajo, entonces usted debe parar el rango en la fórmula para que no cambia cuando se copia hacia abajo.
ANTES.: = BUSCARV (E477; "Agente de Producción 'B3: F5, 3)
AHORA: = BUSCARV (E477; "Agente de Producción '$B$3:$C$5, 3, 0)

Trate de usar, así y decirme si funciona para usted.

b) En relación con calendario laboral , si no se adjunta la hoja de cálculo es muy difícil imaginar cómo es su diseño y lo que realmente necesitan.
b.1) "... En Una hoja Tengo el calendario laboral ..." ¿Cómo es el diseño de esta hoja de cálculo?
b.2) "... si pongo p.e. julio en una celda me devuelva todo el mes de julio con sus colores ..." ¿Qué significa "con sus colores"?

Quedo a la espera de la hoja de cálculo para ver si puedo ayudarte con esto más dudas también.

Estoy seguro de que podemos ayudar.
0
Gracias
¡¡¡¡Cuando vales Mazzaropi!!! De nuevo muchisimas gracias, se me atrancaba la fórmula, respecto a lo del calendario laboral creo que he conseguido solucionarlo de momento, si necesitas lo que sea no dudes en pedirmelo.

Saludos
Publicaciones
1833
Fecha de inscripción
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
250
0
Gracias
Isabelyoplin,

Me alegro de haber ayudado.

Saludos desde Brasil.

Marcílio Lobão