Rellenar el numero de celdas que indique otra Celda

Publicaciones
2
Fecha de inscripción
jueves, 10 de enero de 2019
Estatus
Miembro
Última intervención
viernes, 11 de enero de 2019
- - Última respuesta: qajaqsil
Publicaciones
2
Fecha de inscripción
jueves, 10 de enero de 2019
Estatus
Miembro
Última intervención
viernes, 11 de enero de 2019
- 11 ene 2019 a las 19:52
Hola, quiero crear un libro de excel donde tenga un numero en la celda A1, por ejemplo, 10

Entonces apartir de la celda A5 se vayan rellenando el numero de celdas que tenga A1, con el consecutivo, en este caso si fuera A1 = 10 tendria

A5 = 1
A6 = 2
A7 = 3
A8 = 4
A9 = 5
A10 = 6
A11 = 7
A12 = 8
A13 = 9
A14 = 10

Y si cambio A1 a por ejemplo 5 tenga solo:

A5 = 1
A6 = 2
A7 = 3
A8 = 4
A9 = 5

Gracias


Configuración: Windows / Firefox 64.0
Ver más 

2 respuestas

Mejor respuesta
Publicaciones
44
Fecha de inscripción
viernes, 26 de octubre de 2018
Estatus
Miembro
Última intervención
lunes, 18 de febrero de 2019
6
1
Gracias
Hola, qajaqsil.

En la celda A1 pondrás un numero que variará.

En la celda A5 pon un 1
En la celda A6 pon la formula: =SI(A5<(A$1);A5+1;"FIN")
Ahora arrastra la formula de A5 hasta donde te interese, que sea superior al mayor número que puedas poner en A1.

Cuando cambies el valor de A1, te pondrá el contador de celdas necesario y en el resto te pondrá la palabra FIN.

Espero que te ayude.

Saludos.

Deja un "Gracias" 1

Unas palabras de agradecimiento nunca están de más. Deja tu comentario

CCM 33487 usuarios nos han dicho gracias este mes

Comenta la respuesta de Javier_CCM
Publicaciones
2
Fecha de inscripción
jueves, 10 de enero de 2019
Estatus
Miembro
Última intervención
viernes, 11 de enero de 2019
0
Gracias
La respuesta de Javier_CCM es la que esperaba, muchas gracias

Habia hecho un pequeño codigo para hacerlo, pero es mas facil recordar tu formula

Private Sub Worksheet_Change(ByVal Target As Range)

'--
If Not Target.Address = "$A$1" Then Exit Sub

If Not IsNumeric(Target) Then Exit Sub
'--
Application.EnableEvents = False
Application.ScreenUpdating = False
Range("A5:A1048576").ClearContents

'--
fila = 5
i = 1
For x = 1 To (Target)

columna = 1

Cells(fila + i, columna) = i
i = i + 1

Next
Application.ScreenUpdating = True
Application.EnableEvents = True
End Sub
Comenta la respuesta de qajaqsil