Mi PC no reconoce dispositivos externos USB - Ayuda

Cerrado
Denunciar
Message postés
2
Date d'inscription
lunes, 6 de octubre de 2014
Estatus
Miembro
Última intervención
martes, 7 de octubre de 2014
-
Message postés
86
Date d'inscription
sábado, 4 de octubre de 2014
Estatus
Miembro
Última intervención
domingo, 23 de noviembre de 2014
-
Hola buenas,

En primer lugar decir que soy nuevo en el foro, aunque ya he estado mirando la información al respecto de mi problema y no he conseguido solucionarlo, de ahí que abra un nuevo tema.

Resulta que mi PC, que es un equipo portátil, ha dejado de reconocer los dispositivos USB, bueno mejor dicho, solo me reconoce un pendrive de los varios que tengo y ninguno de mis discos duros externos. Todos los dispositivos externos han sido probados en otros equipos y funcionan a la perfección, por lo tanto problema de los dispositivos externos (pendrives y discos duros) no es.

Al conectar cualquier dispositivo, excepto el que si me reconoce bien, salta el típico mensaje de "No ser reconoce el dispositivo USB - Uno de los dispositivos USB vinculados a este equipo..." y en administrador de dispositivos me aparece como dispositivo desconocido.
Bueno pues he intentado de todo:

- Desinstalar todos los drivers relacionados con USB, reiniciar y ver si me los reinstala de nuevo y reconoce a los dispositivos.
- Administración de discos por si hubiese una letra asignada a la unidad repetida (pero como no lo reconoce, no aparece allí)
- He probado en el mismo equipo cambiando de sistema operativo los dispositivos externos en XP y Windows 7

NADA DE TODO LO ANTERIOR FUNCIONÓ (y seguro que me dejo más de una de las pruebas que he hecho)

Se puede llegar a pensar que es de controladores, pero no, pues todos están bien y no aparecen conflictos e administrador de dispositivos.

Se puede llegar a pensar que puede ser de hardware, pero es que si hay un pendrive que si lo reconoce y a velocidad 2.0

Lo único que me funciona es desinstalar el "Controlador de host de PCI a USB mejorado". Así me reconoce todos los dispositivos pero claro, a una velocidad irritantemente lenta.

Por lo tanto, no intuyo que sea de controladores, me inclinaría más a porque sea de hardware, pero claro como digo, hay un pendrive que si me lo reconoce.

Si alguno me pudiese ayudar le estaría tremendamente agradecido, a ver si puedo solucionar este problema. Lo que intento es que todos los dispositivos sean reconocidos como USB 2.0 tal como pasa con el pendrive que si me reconoce y al igual que pasa al conectar todos mis discos y pendrives en en otros equipos.

Saludos y gracias de antemano!!!!!

2 respuestas

Message postés
86
Date d'inscription
sábado, 4 de octubre de 2014
Estatus
Miembro
Última intervención
domingo, 23 de noviembre de 2014
39
problema de hardware no es por q sino cuando des instalas el controlador de host de PCI a USB mejorado, tampoco tendría por q andarte.

quedate tranquilo q es un problema de compatibilidad en el controlador ese....

ahora vamos a lo q importante por q es el problema,

instalaste algun suite de celulares? o algun lector de tarjetas o cualquier driver de esas clase q pueda llegar a crear o modificar el Mpfilt.sys recientemente??

podrías eliminar ese driver como lo haces pero asegurate de dejar el registro limpio para q cunado reinicies la pc se haga una instalacion desde 0 de dicho driver y no queden configuraciones guardadas, tambien antes de de limpiar el registro elimina el archivo "Mpfilt.sys"

para limpiar el registro te recomiendo q uses el ccleaner por q obviamente no recuerdo las entradas a eliminar para decirte q lo hagas manualmente por medio del regedit

de ultima te lo googleo mañana. saludos suerte
Message postés
2
Date d'inscription
lunes, 6 de octubre de 2014
Estatus
Miembro
Última intervención
martes, 7 de octubre de 2014

Hola 496ktliz. En primer lugar gracias por tu aporte. Decirte que en su día si que lo instalé, un driver de samsung, pues no me reconocía tampoco el teléfono. Tras instalarlo me funcionaba todo bien, pero llegó el día en que todo dejó de funcionar (y no creo que fuese por instalar un driver de samsung, pues hubo un tiempo considerable en que funcionaba todo).
Tras ello he formateado y tengo limpio el registro así como todo el PC, y sigue sin funcionarme ninguno de los dispositivos externos excepto ese pendrive que si que digo que funciona y lo lee sin problemas.
Por lo tanto creo que el registro está limpio y de ahí no es.

Muchas gracias de nuevo por tu info. Seguiré buscando soluciones!!

Saludos
Message postés
86
Date d'inscription
sábado, 4 de octubre de 2014
Estatus
Miembro
Última intervención
domingo, 23 de noviembre de 2014
39
ha no había leido lo del formateo, q SO instalaste? pero si igualmente la solucion temporal sigue siendo eso, yo probaria igual, eliminar el Mpfilt.sys y despues ... en el registro borra la carpeta HKEY_LOCAL_MACHINE\system\currentcontrolset\services\mpfilt

busca la clave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000} y borra la clave "Lowerfilters".

después reinicia