Condicion excel

Cerrado
Denunciar
Message postés
2
Date d'inscription
lunes, 24 de marzo de 2014
Estatus
Miembro
Última intervención
martes, 25 de marzo de 2014
-
 WEAFFY -
como puedo dejar valor de celda estatica si se cumple verdadero

ejemplo

Celda A1
a1= 20/03/14

Celda B1
( AQUI SE VACIARAN DATOS SEGUN CONDICION)

CONDICION
SI en la celda C1 existe " ~ " se tiene que cumplir la formula arriba

Celda B1 ( CONSIDERAR QUE LA FECHA DE hoy() SEA 24/03/14
b1=hoy()-a1

SI EN LA CONDICION C1 EXITIERA " X " , YA NO DEBERA OPERAR LA CONDICION
SOLO DEJAR ESTATICO EL RESULTADO 4

COMO HACER ESTE PASO FINAL ???

1 respuesta

Message postés
1950
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
domingo, 9 de enero de 2022
492
weafly, Buenos dias.

No sé si he entendido bien su pregunta.

B1 --> =SI(C1="~" ; HOY()-A1 ; 4)

Use el propio separador de argumentos en su versión de Excel.
Coma( , ) o punto y coma ( ; ).

¿Era eso lo que querías?
Espero haber ayudado.
0
Te agradezco tu atencion ,

Exlicare un poco mas claro paral¿que se entienda....

A B C
1 Fecha Inicial Dias Rezagados STATUS
2 20/03/2014 5 ~

EN DIAS REZAGADOS SE LLEVARAA CABO SIEMPRE Y CUANDO LA CELDA C2 = ~ .
PERO SI EL STATUS TIENE EL VALOR " X " , LA CELDA B2 TIENE QUE CONSERVAR EL
VALOR ACTUAL Y NO DEVOLVER EL VALOR FALSO

PARA B2
=SI(C2=" ~ ",HOY() - B2)
LA RESPUESTA QUE ME DISTE =SI(C2=" ~ ",HOY() - B2,4)
UNICAMENTE DEVUELVE EL NUMERO 4 SI EL CASO ES FALSO, NO QUIERO ESO


CASO NUMERO 2

A B C D
1 Fecha Inicial Dias Rezagados STATUS Dias Efectivos
2 20/03/2014 CERRADO X 5


AQUI UTILIZO OPCION SI FUERA FALSO B2 =SI(C2="~",HOY()-A2,"CERRADO")
AQUI ES FALSO EXISTE UNA " X "

EN LA CELDA D2 =SI(B2="CERRADO",HOY()-A2

EL PROBLEMA ESTA CUANDO MODIFICAS A2 DELIBERADAMENTE, ES DECIR
SI TIENES 20/03/2014 Y LE PONES 22/03/2014 TE DEVUELVE EL VALOR
3 EN LA CELDA D2 . TIENE QUE QUEDAR FIJO A PESAR DE MODIFICAR

ESPERO ESTA VEZ ME HAYA EXPLICADO

GRACIAS
0