Formula para sacar numero primo [Cerrado]

lizzy - 5 feb 2010 a las 18:27 - Última respuesta: epiro1 16 Publicaciones lunes, 16 de mayo de 2016Fecha de inscripción viernes, 27 de mayo de 2016 Última intervención
- 19 may 2016 a las 02:56
Hola,
necesito saber la formula para saber si es un numero primo o no
Ver más 

10 respuestas

Programadores - 7 abr 2010 a las 22:27
+10
Vota
aqui la factorial de un numero echo por los alumnos de la UAP
mas facil no podria estar

Public Class Form1
Sub factorial()

Dim a As Integer = Val(Me.TextBox1.Text)

Dim c As Integer = 1

For i As Integer = 1 To a

c = c * i

Next

MsgBox(c)

End Sub

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
factorial()
End Sub
End Class
¿Te sirvió esta respuesta?  
Zeruch 593 Publicaciones viernes, 16 de enero de 2009Fecha de inscripción jueves, 11 de noviembre de 2010 Última intervención - 5 feb 2010 a las 18:32
+1
Vota
6
leete esto http://es.wikipedia.org/wiki/F%C3%B3rmula_de_los_n%C3%BAmeros_primos y te vas a dar cuenta de la verdad
Hay qierro saber algo mas
ueur
q bien .
todo esta bien pero no entendi
no me compete es demasiado sencillo......
no entiendo nada 3======================D
no entiendo nada 3======================D
epiro1 16 Publicaciones lunes, 16 de mayo de 2016Fecha de inscripción viernes, 27 de mayo de 2016 Última intervención - 19 may 2016 a las 02:46
0
Vota
1
Hola estimado.

La siguiente fórmula puede servir. Es Matricial; es decir, una vez introducida en la barra de fórmulas no hay que pulsar Enter, sino que hay que pulsar a la vez Control, Mayus, Enter.

Se supone que el número lo tienes en la celda B2.
El resultado de la fórmula indicará VERDADERO si el Nº es Primo, y FALSO si no lo es.

=SI(ES.PAR(B2);FALSO;SUMA(--(MULTIPLO.INFERIOR(B2;FILA(INDIRECTO("1:"&ENTERO(REDONDEAR.MAS(RAIZ(B2);0)/2)+1))*2-1)=B2))=1)

Un saludo
epiro1 16 Publicaciones lunes, 16 de mayo de 2016Fecha de inscripción viernes, 27 de mayo de 2016 Última intervención - 19 may 2016 a las 02:56
NOTA. Aunque la fórmula indicará que 2 y 3 no son primos, en realidad sí lo son.
Al parecer la fórmula es válida hasta el número 17.179.606.993