Programa para ordenar números de menor a mayor [Resuelto/Cerrado]

-
Hola,

Estoy tratando de hacer correr este programa en borland c++5.0 pero al correrlo me da otros resultados y no el que deseo de ordenar los números de menor a mayor y no sé qué he hecho mal porfa ayuda.

#include <iostream>
#include <conio>
void main()
{int a,b,c,aux;
clrscr();
cout<<"ingrese los tres datos:";
cin>>a;
cin>>b;
cin>>c;
if(a<b)
{aux=a;
a=b;
b=aux;
}
if(a<c)
{aux=a;
a=c;
c=aux;
}
if(b<c)
{aux=b;
b=c;
c=aux;
}
cout<<"los datos ordenados son:";
cout<<a<<""<<b<<""<<c;
getch();
}
Configuración: Windows XP Safari 532.0
Ver más 

10 respuestas

Mejor respuesta
aprobada por Carlos Villagómez el 30 ago. 2019
55
Gracias
Hola,

#include<stdio.h>
#include<conio.h>
main()
{
int a,b,c;
printf("ingrese tres numeros");
scanf("%d%d%d",&a,&b,&c);
if(c>b&&b>a) printf("el orden es el siguiente %d%d%d",a,b,c);
else if(a>b&&b>c)printf("el orden es el siguiente %d%d%d",c,b,a);
else if(a>b&&c>a)printf("el orden es el siguiente %d%d%d",b,a,c);
else if(a>c&&c>b)printf("el orden es el siguiente %d%d%d",b,c,a);
else if(b>c&&b>a&&a>c)printf("el orden es el siguiente %d %d %d",c,a,b);
else printf("el orden es el siguiente %d%d%d",a,c,b);

getch();
}

Deja un "Gracias" 55

¡Estamos felices de haberte ayudado! ¿Te hemos sido de ayuda? ¡Déjanos un comentario! Evalúa a CCM

CCM 34652 usuarios nos han dicho gracias este mes

otoshi
Publicaciones
1
Fecha de inscripción
jueves, 27 de diciembre de 2012
Estatus
Miembro
Última intervención
jueves, 27 de diciembre de 2012
-
El mejor que he visto hasta el momento.... por lo sencillo y muy basico para los que estamos aprendiendo, muchas gracias
Dayi_855
Publicaciones
2
Fecha de inscripción
lunes, 17 de marzo de 2014
Estatus
Miembro
Última intervención
lunes, 17 de marzo de 2014
-
Gracias me ayudaron mucho estos codigos!!
Dayi_855
Publicaciones
2
Fecha de inscripción
lunes, 17 de marzo de 2014
Estatus
Miembro
Última intervención
lunes, 17 de marzo de 2014
-
pero tengo una interrogativa como puedo hacer para q tambien me salga ordenado los valores si dos valores son iguales osea:
A=4
B=6
C=4
43
Gracias
pues solo tenias unos errores mira este telo ordena de menor a mayor
#include <iostream>
#include <conio>
void main()
{int a,b,c,aux;
clrscr();
cout<<"ingrese los tres datos:";
cin>>a;
cin>>b;
cin>>c;
if(a>b)
{aux=a;
a=b;
b=aux;
}
if(a>c)
{aux=a;
a=c;
c=aux;
}
if(b>c)
{aux=b;
b=c;
c=aux;
}
cout<<"los datos ordenados son:";
cout<<a<<""<<b<<""<<c;
getch();
}
> tochana -
jajaja tochana?
chupadme la mingaaaaa
chupame la minga dominga que vengo de franciaaa chupame la minga dominga que lleva sustanciaaaa
Matrix7777
Publicaciones
6
Fecha de inscripción
martes, 11 de agosto de 2015
Estatus
Miembro
Última intervención
domingo, 16 de agosto de 2015
-
joder llege tarde para el bullyng
esoo gracias compaaaa la re buena, nos pillamos, un saludo pa mi mama, holaaa mamaaaa
Publicaciones
1
Fecha de inscripción
lunes, 26 de abril de 2010
Estatus
Miembro
Última intervención
lunes, 26 de abril de 2010
15
15
Gracias
#include <iostream.h>// el problema era la extension de la libreria .h
#include <conio.h>
void main()
{int a,b,c,aux;
clrscr();
cout<<"ingrese los tres datos:";
cin>>a;
cin>>b;
cin>>c;
if(a<b)
{aux=a;
a=b;
b=aux;
}
if(a<c)
{aux=a;
a=c;
c=aux;
}
if(b<c)
{aux=b;
b=c;
c=aux;
}
cout<<"los datos ordenados son:";
cout<<a<<""<<b<<""<<c;
getch();
}
14
Gracias
* Pedir tres números enteros e imprimirlos de mayor a menor

#include <cstdlib>
#include <iostream>
#include "math.h"
#include <conio.h>

using namespace std;

int main(int argc, char *argv[])
{

{int a,b,c,aux;

cout<<"ingrese los tres numeros enteros :"<<endl;
cout<<"el primero :";
cin>>a;
cout<<"el segundo :";
cin>>b;
cout<<"el tersero :";
cin>>c;
if(a<b)
{
aux=a;
a=b;
b=aux;
}
if(a<c)
{
aux=a;
a=c;
c=aux;
}

if(b<c)
{
aux=b;
b=c;
c=aux;

}
cout<<"los numeros ordenados son :";
cout<<a<<" , "<<b<<" , "<<c<<endl;

system("PAUSE");
return EXIT_SUCCESS;

}
}
-
chicos comom se as
Que alguien me etsplique O_O)7 ??
q mal pero q mal
como le puedo en un programa que de los saltos
para saltos solo es necesario endl;
13
Gracias
hola man soy estudiante de informatica del segundo semetres en la unerg guarico venezuela y me mandaron a realizar un programa parecido que acabo de culminar aki esta compara con el de vos

#include <iostream>

using namespace std;
int main()
{
int a,b,c,orden;

cout<<"ingrese primero numero"<<endl;
cin>>a;
cout<<"ingrese segundo numero:"<<endl;
cin>>b;
cout<<"ingrese tercer numoer:"<<endl;
cin>>c;
if(a>b)
{orden=a;
a=b;
b=orden;
}
if(a>c)
{orden=a;
a=c;
c=orden;
}
if(b>c)
{orden=b;
b=c;
c=orden;
}
cout<<"los datos ordenados son:"<<endl;
cout<<"1er: "<<a<<endl;
cout<<"2do: "<<b<<endl;
cout<<"3er: "<<c<<endl;
system("PAUSE");
return EXIT_SUCCESS;
}
como le hago en 5 números de mayor a menor
WilliamCV
Publicaciones
1
Fecha de inscripción
lunes, 21 de agosto de 2017
Estatus
Miembro
Última intervención
lunes, 21 de agosto de 2017
-
hey, gracias por tu código, lo necesitaba de comparación de 5 números y fue fácil modificarlo, en serio gracias
10
Gracias
#include <iostream.h>//el prblema es la extension de la libreria .h
#include <conio.h>
void main()
{int a,b,c,aux;
clrscr();
cout<<"ingrese los tres datos:";
cin>>a;
cin>>b;
cin>>c;
if(a<b)
{aux=a;
a=b;
b=aux;
}
if(a<c)
{aux=a;
a=c;
c=aux;
}
if(b<c)
{aux=b;
b=c;
c=aux;
}
cout<<"los datos ordenados son:";
cout<<a<<""<<b<<""<<c;
getch();
}
a mi me sirvio, lo que pasa esq no he llevado aun aux asi q no la puedo utilizar en el otro caso orden tampoc lo deberia de utilizar porq es basado a lo q lleve en clases pero gracias me han dad buenas ideas
una pregunta el aux es para almacenar cierto y despues lo compara con los demas numeros?
bueno andrea y brunella se cree toda pero es mentirosa brunella eres cerda cochina asquerosa fea cochina la que no se baña
si , esa es la funcion del auxiliar almacenar un dato de una variable para luego poder ser utilizad dependidiendo de la funcionalidad del programa k vallamos a realizar...¡¡¡¡¡¡¡¡¡¡
hola y bay son estu
6
Gracias
a la hora de imprimir debes poner primero c, luego b y por ultimo a
6
Gracias
numeros de mayor a menor
EStoy haciendo el mismo programa en pseint pero no me da; quiero saber cuál es el error porque no lo encuentro ... muchas gracias


Proceso ordendescendente
Escribir "";//
Escribir "PROGRAMA PARA IMPRIMIR TRES NUMEROS INGRESADOS EN FORMA DESCENDENTE";
Escribir "INGRESAR EL PRIMER NUMERO";
Leer a;
Escribir "INGRESAR EL SEGUNDO NUMERO";
Leer b;
Escribir "INGRESAR EL TERCER NUMERO";
Leer c;
Escribir "";//
Escribir "";//
Si a>b y a>c Entonces
mayor<-a;
medio<-b;
menor<-c;
Sino
Si a>c y a>b Entonces
mayor<-a;
medio<-c;
menor<-b;
Sino
Si b>a y b>c Entonces
mayor<-b;
medio<-a;
menor<-c;
Sino
Si b>c y b>a Entonces
mayor<-b;
medio<-c;
menor<-a;
Sino
Si c>a y c>b entonces
mayor<-c;
medio<-a;
menor<-b;
Sino
Si c>b y c>a entonces
mayor<-c;
medio<-b;
menor<-a;
Finsi
Finsi
FinSi
Finsi
Finsi
FinSi
Escribir "EL NUMERO MAYOR ES: ",mayor;
Escribir "";//
Escribir "EL NUMERO DEL MEDIO ES: ",medio;
Escribir "";//
Escribir "EL NUMERO MENOR ES: ",menor;
Escribir "";//
FinProceso
-
excelente
5
Gracias
nECESITO RESOLVER ESTE PROBLEMA quien me ayuda.. necesito desarrollar el programa que compare y diga quien es el mayor de 5 numeros enteros
#include "stdio.h"
void main()
{
int NUM1, NUM2;
clrscr();
textcolor(14);
gotoxy(32,4);cprintf("TOMA DE DESICION");
gotoxy(29,11);cprintf("KEVIN ALEXIS VILLAREAL");
gotoxy(35,13);cprintf("CODIGO 37");
gotoxy(24,19);cprintf("INSTITUCION EDUCATIVA SAN ISIDORO");
gotoxy(28,20);cprintf("TECNOLOGIA E INFORMATICA");
gotoxy(35,21);cprintf("GRADO10-3");
gotoxy(32,22);cprintf("ABRIL 21 DE 2014");
getche();
clrscr();
textcolor(14);
gotoxy(30,4);cprintf("INSTRUCCION IF - ELSE");
gotoxy(22,11);cprintf("HALLAR EL MUMERO MAYOR DE DOS NUMEROS");
gotoxy(27,13);cprintf("DIGITE EL PRIMER NUMERO: ");
scanf("%d",&NUM1);
gotoxy(27,14);cprintf("DIGITE EL SEGUNDO NUMERO: ");
scanf("%d",&NUM2);
if (NUM1 > NUM2)
{
gotoxy(28,18);cprintf("EL NUMERO MAYOR ES: ");
gotoxy(48,18);cprintf("%d",NUM1);
}
else
{
gotoxy(28,18);cprintf("EL NUMERO ES MAYOR ES:");
gotoxy(48,18);cprintf("%d",NUM2);
}
getche();
}
3
Gracias
#include <iostream>
#include <conio>
void main()
{int a,b,c,aux;
clrscr();
cout<<"ingrese los tres datos:";
cin>>a;
cin>>b;
cin>>c;
if(a>b)
{aux=a;
a=b;
b=aux;
}
if(a>c)
{aux=a;
a=c;
c=aux;
}
if(b>c)
{aux=b;
b=c;
c=aux;
}
cout<<"los datos ordenados son:";
cout<<a<<""<<b<<""<<c;
getch();
}