No puedo utilizar una variable fecha en una formula, ayuda [Resuelto]

Denunciar
Message postés
7
Date d'inscription
martes, 2 de febrero de 2021
Estatus
Miembro
Última intervención
martes, 2 de febrero de 2021
-
Message postés
7
Date d'inscription
martes, 2 de febrero de 2021
Estatus
Miembro
Última intervención
martes, 2 de febrero de 2021
-
Hola,
Tengo una formula: =SUMAR.SI.CONJUNTO(TRASLADOS!$O$3:$O$992;TRASLADOS!$A$3:$A$992;">=01/01/2021";TRASLADOS!$A$3:$A$992;"<=31/01/2021") pero si en vez de poner las fechas, pongo =SUMAR.SI.CONJUNTO(TRASLADOS!$O$3:$O$992;TRASLADOS!$A$3:$A$992;">=C1";TRASLADOS!$A$3:$A$992;"<=C2") donde C1 es 01/01/2021 y C2 es 31/01/2021
el resultado siempre es 0
Por favor si alguien me puede ayudar con alguna idea.
Muchas gracias
Maricel

Configuración: Windows / Chrome 88.0.4324.104

13 respuestas

Message postés
747
Date d'inscription
lunes, 7 de abril de 2014
Estatus
Contribuidor
Última intervención
martes, 2 de febrero de 2021
1.003
Buenas tardes,

He encontrado dónde estaba el fallo.

Tu fórmula es la siguiente:

=SUMAR.SI.CONJUNTO(TRASLADOS!$Q$3:$Q$992;TRASLADOS!$A$3:$A$992;">=C1";TRASLADOS!$A$3:$A$992;"<=C2")

El problema en esta es que te está cogiendo como referencia literal C2 y C1 por lo que siempre te va a dar 0 porque da como respuesta un no.

=SUMAR.SI.CONJUNTO(TRASLADOS!$Q$3:$Q$992;TRASLADOS!$A$3:$A$992;">="&C1;TRASLADOS!$A$3:$A$992;"<="&C2)

En esta formula, ponemos la formula así: "<="&C1 y "<="&C2

Con esto lo que te hace es coger que sea menor o igual que el valor dentro de la celda seleccionada.
1
Gracias

¡Estamos felices de haberte ayudado! ¿Te hemos sido de ayuda? ¡Déjanos un comentario! Evalúa a CCM

CCM 27205 usuarios nos han dicho gracias este mes

Message postés
747
Date d'inscription
lunes, 7 de abril de 2014
Estatus
Contribuidor
Última intervención
martes, 2 de febrero de 2021
1.003
Buenas tardes,

No tengo mucho conocimiento de excel pero tienes la celda en formato Fecha?
Message postés
7
Date d'inscription
martes, 2 de febrero de 2021
Estatus
Miembro
Última intervención
martes, 2 de febrero de 2021

si, en formato fecha
Message postés
747
Date d'inscription
lunes, 7 de abril de 2014
Estatus
Contribuidor
Última intervención
martes, 2 de febrero de 2021
1.003
Puedes probar a poner las fechas en formato Mes / Dia / año en lugar de Dia / mes / año?
Message postés
747
Date d'inscription
lunes, 7 de abril de 2014
Estatus
Contribuidor
Última intervención
martes, 2 de febrero de 2021
1.003
Es decir al revés disculpa.
Message postés
7
Date d'inscription
martes, 2 de febrero de 2021
Estatus
Miembro
Última intervención
martes, 2 de febrero de 2021

ya probé con todos los tipos de formatos de fecha y nada.
Message postés
747
Date d'inscription
lunes, 7 de abril de 2014
Estatus
Contribuidor
Última intervención
martes, 2 de febrero de 2021
1.003
Hay alguna forma en la que me puedas facilitar el excel para mirar y hacer pruebas??
Message postés
7
Date d'inscription
martes, 2 de febrero de 2021
Estatus
Miembro
Última intervención
martes, 2 de febrero de 2021

si, tiene datos de prueba y no es muy pesado, como lo subo o a donde lo mando?
Message postés
747
Date d'inscription
lunes, 7 de abril de 2014
Estatus
Contribuidor
Última intervención
martes, 2 de febrero de 2021
1.003
Mandamelo por privado por favor.
Message postés
7
Date d'inscription
martes, 2 de febrero de 2021
Estatus
Miembro
Última intervención
martes, 2 de febrero de 2021

primero la tengo que subir a algun lado, si?
Message postés
747
Date d'inscription
lunes, 7 de abril de 2014
Estatus
Contribuidor
Última intervención
martes, 2 de febrero de 2021
1.003
Mira el privado por favor.
Message postés
7
Date d'inscription
martes, 2 de febrero de 2021
Estatus
Miembro
Última intervención
martes, 2 de febrero de 2021

Guuty,
Ahi te la mandé, muchas gracias por lo que puedas hacer y sobre todo por la voluntad de ayudar!
Beso
Maricel
Message postés
7
Date d'inscription
martes, 2 de febrero de 2021
Estatus
Miembro
Última intervención
martes, 2 de febrero de 2021

Muchísimas gracias Guuty, problema solucionado!
Un genio! :)

¡Suscríbete a nuestra Newsletter!

Recibe nuestros mejores artículos

¡Suscríbete a nuestra Newsletter!