Función lógica SI

Cerrado
yeudiman
Message postés
4
Date d'inscription
viernes, 18 de noviembre de 2016
Estatus
Miembro
Última intervención
domingo, 20 de noviembre de 2016
- 20 nov 2016 a las 00:43
Mazzaropi
Message postés
1963
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
lunes, 25 de abril de 2022
- 20 nov 2016 a las 15:43
Categoría/Enero/Febrero/Marzo/Total Enero/Total Febrero/ Total Marzo/Precios
1750
B 300 330 366,3

Este es el planteo del problema:Si la
Categoría es igual a A, debe multiplicar la cantidad correspondiente de cada mes por el Precio
de A; de no ser así, Si la Categoría es igual a B, debe multiplicar la cantidad correspondiente de
cada mes por el Precio de B; en caso contrario Si la Categoría es igual a C, debe multiplicar la
cantidad correspondiente de cada mes por el Precio de C; si esto tampoco se cumple, o sea Si la
Categoría es igual a D, debe multiplicar la cantidad correspondiente de cada mes por el Precio
de D.
Como realizo la formula incluyendo función lógica SI con sus respectivas combinaciones (Y, O,
SI anidado)

1 respuesta

Mazzaropi
Message postés
1963
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
lunes, 25 de abril de 2022
504
20 nov 2016 a las 15:43
yeudiman, Buenos dias.

La disposición de las células se confunden.
Usted no ha dicho cómo se colocarán estos precios en la hoja de trabajo.

Así que hice un pequeño ejemplo con lo que pude entender:

https://www.sendspace.com/file/2nydxz

La fórmula en la celda E2 es el siguiente:
=SI($A2="A"; 10; SI($A2="B"; 20; SI($A2="C"; 30; SI($A2="D"; 40; 0)))) * B2
Sólo tienes que arrastrar la fórmula a la derecha y luego hacia abajo.

También puede utilizar el precio directamente en las células. Así que la fórmula podría ser:
=SI($A2="A"; $K$2; SI($A2="B"; $K$3; SI($A2="C"; $K$4; SI($A2="D"; $K$5; 0)))) * B2

Era eso lo que querías?
Espero haber ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
0