Perdido con una fórmula

Resuelto/Cerrado
Galantesaa Mensajes enviados 2 Fecha de inscripción jueves, 20 de octubre de 2016 Estatus Miembro Última intervención jueves, 20 de octubre de 2016 - 20 oct 2016 a las 18:12
Galantesaa Mensajes enviados 2 Fecha de inscripción jueves, 20 de octubre de 2016 Estatus Miembro Última intervención jueves, 20 de octubre de 2016 - 20 oct 2016 a las 20:32
Hola,
Buenos días, estoy haciendo una fórmula la cual dependiendo la condición que me traiga un número o una fecha pero en el resultado que me trae no logro hacer que me dé la fecha o el número porque si el foro aro de la casilla le pongo fecha me trae sólo formato fecha y si le pongo formato número me trae sólo numwro.
Ejemplo

A1 = 21/09/2016
A2 = 10
Fórmula.. Si(a2=10;a2;a1)

Necesito que el resultado sea 10 o 21/09/2016


1 respuesta

Mazzaropi Mensajes enviados 1985 Fecha de inscripción lunes, 16 de agosto de 2010 Estatus Contribuidor Última intervención miércoles, 24 de mayo de 2023 563
20 oct 2016 a las 19:41
Galantesaa, Buenas tardes.

Pruebe esta fórmula.

Supongamos D4.
La celda debe estar en el formato general.

D4 --> =SI(A2=10; A2; TEXTO(A1;"dd/mm/aaaa"))

Nota:
El resultado con el formato de fecha vendrá como texto.
Si desea hacer alguna operación utilizando esta celda, recuerda esto.

Por favor, díganos si la fórmula funcionó.
Espero haber ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
Galantesaa Mensajes enviados 2 Fecha de inscripción jueves, 20 de octubre de 2016 Estatus Miembro Última intervención jueves, 20 de octubre de 2016
20 oct 2016 a las 20:32
Muchas gracias por la respuesta, salvaste mi día!!!!
0