Haz una pregunta Denunciar

Formula de excel, importar datos entre hojas

ale - Última respuesta el 28 ago 2015, 02:19
Hola,
tengo 2 libros de excel en uno tengo un listado de modelos de relojes con sus precios ejemplo
modelo precio
2089 $5430
y en el otro libro tengo las mismas columnas como hago para que a la hora de que yo ponga el modelo automaticamente se ponga el precio?
Sigue leyendo 
Respuesta
+33
moins plus
Hola.
Hay más de una forma de hacerlo dependiendo de tu nivel de expertise. Te voy a dar la solución más sencilla pero puede que no sea la mejor, más rápida y/o robusta.
Pongamos que el libro excel que le pones el codigo del reloj se llama FacturaReloj.xls y el libro que tiene los precios es el ListaPreciosRelojes.xls. Y supongamos que la matriz de Relojes-Precio (n filas * 2 columnas) está en la hoja1 en el Rango A2:B1000 (La primera fila tiene los títulos).

La formula - iria en la celda B1 del libro FacturaReloj.xls por ejemplo - en excel 2010 sería
=BUSCAR(A1;'[ListaPreciosRelojes.xlsm]Hoja1'!$A$2:$A$1000;'[ListaPreciosRelojes.xlsm]Hoja1'!$B$2:$B$1000)

A1 es la celda a la que le pones el código del reloj y al lado la formula te trae el precio.

La limitante es que los códigos de los relojes deben estar ordenados en forma ascendente, es decir el codigo 15-aa100 va antes que el 20-aa100 y este antes que el AA-aa100. Por otra parte, no recuerdo si en el excel anterior estaba con esta sintaxis la formula buscar pero en tal caso si no te funcionara prueba con:

=BUSCARV(A1;'[ListaPreciosRelojes.xlsm]Hoja1'!$A$2:$B$1000;2)

Siempre que en la columna B estén los precios. El 3er termino de la función, que tiene el valor 2, le indica que tiene que traer la 2da columna de la matriz cuando encuentre el valor dado en A1.

Si la lista la tienes que tener desordenada entonces hay soluciones más tediosas, con más formulas y más complicadas pero eso lo dejo para cuando me lo digas.

Saludos.
lop- 26 sep 2014, 05:11
como hago para que una tabla que tenga me modifique otra sin poder tocar la otra
Responder
Juan- 28 ago 2015, 02:19
Por medio de Formula ya sea Consultav o Buscarv
Responder
k-rolina- 14 jun 2015, 22:12
trengo una tabla con 2.380 datos de alumnos
RUN - DV - PATERNO - MATERNO - NOMBRES, ETC

en otra hoja de excel debo crear una lista en este orden y no con todos los datos como la base madre

PATERNO - MATERNO - RUN

lo he intentado con filtro avanzado pero no me sirve ya que no necesito todas las columnas sino solo alguna de ellas.-

ayuda por favor.
Responder
AlejitoMac- 29 jul 2015, 21:26
Oculta las columnas y solo dejas la de RUN-PATERNO-MATERNO,Copias los datos en un libro nuevo y listo.
Responder
Juan k-rolina - 28 ago 2015, 02:18
se Puede Usar la consulta en consultav
Responder
Deja tu comentario
El documento «formula de excel, importar datos entre hojas» de CCM (es.ccm.net) se encuentra disponible bajo una licencia Creative Commons. Puedes copiarlo o modificarlo siempre y cuando respetes las condiciones de dicha licencia y des crédito a CCM.

¿Todavía no eres usuario?

¡Inscríbete, gratis y en menos de un minuto!

Los miembros obtienen más respuestas que los usuarios anónimos.

Ser miembro te permite llevar un seguimiento detallado de tus consultas.

Ser miembro te permite disfrutar de opciones adicionales.