Ayuda Algoritmo

Cerrado
Wilf_8055
Message postés
4
Date d'inscription
jueves, 27 de agosto de 2020
Estatus
Miembro
Última intervención
viernes, 4 de septiembre de 2020
- 31 ago 2020 a las 17:48
Wilf_8055
Message postés
4
Date d'inscription
jueves, 27 de agosto de 2020
Estatus
Miembro
Última intervención
viernes, 4 de septiembre de 2020
- 2 sep 2020 a las 14:43
Hola, necesito su ayuda. Por favor me asignaron el enunciado en el trabajo y añado mi resolución. Necesito saber sus criticas sobre mi Pseudocódigo.



Proceso que permita ingresar una serie de números enteros (Enter para fin)
Imprimir al final del trabajo, la cantidad de valores pares que fueron
ingresados, la cantidad de valores impares y la suma total de los valores
impares mayores a 20.



ENTORNO

W_NUMERO es numerico
CON_PAR es númerico
CON_IMPAR es númerico
SUMA es númerico


inicio
PROCESO_INCIAL
mientras W_NUMERO /10
PROCESO_PRINCIPAL
fin_mientras
PROCESO_FINAL
fin

RUTINAS
PROCESO_INICIAL
Ingresar "Número" W_NUMERO
CON_PAR = 0
CON_IMPAR = 0
retorno

PROCESO_PRINCIPAL:
si (numero/2 =0)
CON_PAR = CON_PAR + 1

sino

CON_IMPAR = CON_IMPAR + 1
CON_IMPAR > 20
SUMA = SUMA + CON_IMPAR

fin_si
retorno

PROCESO_FINAL:
Imprimir"Cantidad numeros pares" CON_PAR
Imprimir"Cantidad numeros impares" CON_IMPAR
Imprimir"Suma valores Impares mayores a 20" SUMA
retorno

2 respuestas

misterdekus
Message postés
468
Date d'inscription
miércoles, 10 de enero de 2018
Estatus
Miembro
Última intervención
miércoles, 1 de junio de 2022
121
2 sep 2020 a las 04:02
El único problema es condición

número/2 = 0

Que debería ser

número mod 2 = 0
O
número % 2 = 0

Recordando que mod es residuo
1
Wilf_8055
Message postés
4
Date d'inscription
jueves, 27 de agosto de 2020
Estatus
Miembro
Última intervención
viernes, 4 de septiembre de 2020

2 sep 2020 a las 14:43
Muchas Gracias por tu aporte. Éxitos.
0