Ayuda Lógica Programación

Denunciar
Message postés
4
Date d'inscription
jueves, 27 de agosto de 2020
Estatus
Miembro
Última intervención
viernes, 4 de septiembre de 2020
-
Message postés
61
Date d'inscription
miércoles, 26 de agosto de 2020
Estatus
Miembro
Última intervención
viernes, 28 de agosto de 2020
-
Hola a todos. Me asignaron un enunciado en la empresa, lastimosamente desconozco si mi resolución es la correcta. Me seria de gran utilidad si pudieran señalar algún error o sugerencia. Desde ya muchas gracias.





Asignar los valores de los datos de prueba a cinco variables. Ordenarlos en forma
ascendente usando una sexta variable como auxiliar. Posteriormente efectuar
la suma de las dos primeras y al resultado restarle la suma de la tercera y la cuarta.
El resultado multiplicar por la quinta y dejar el resultado final en la sexta.
Todo esto se debe hacer sin destruir los contenidos de las demás variables. Imprimir
el resultado final.

DATOS DE PRUEBA: 3 7 -3 -6 -16



ENTORNO
W_A es numerico
W_B es numerico
W_C es numerico
W_D es numerico
W_E es numerico
AUX es numerico
W_RESULTADO es numerico

CUERPO PRINCIPAL
inicio
ejecutar PROCESO_INICIAL
ejecutar PROCESO_PRINCIPAL
ejecutar PROCESO_FINAL
fin

PROCESO_INICIAL
imprimir "Asignación de valores"
leer W_A
leer W_B
leer W_C
leer W_D
leer W_E
retorno

PROCESO_PRINCIPAL
Sino
Imprimir E
Imprimir A
Imprimir B
Imprimir D
Imprimir C

FinSi

W_RESULTADO = ((W_A + W_B) - (W_C + W_D)) * 5

AUX = W_RESULTADO

retorno

PROCESO_FINAL

Imprimir "Auxiliar" AUXILIAR

retorno

2 respuestas

Message postés
371
Date d'inscription
miércoles, 10 de enero de 2018
Estatus
Miembro
Última intervención
sábado, 5 de septiembre de 2020
58
El único error que veo es este....

Sino
Imprimir E
Imprimir A
Imprimir B
Imprimir D
Imprimir C

FinSi

El Sino y FinSi esta de más si no tienes el si ( condición) entonces

Igualmente A , B , C , D y E , no existen
A lo mejor quisiste decir W_A , W_B , etc

Solo corrige eso , por lo demás está bien
1
Gracias

¡Estamos felices de haberte ayudado! ¿Te hemos sido de ayuda? ¡Déjanos un comentario! Evalúa a CCM

CCM 35715 usuarios nos han dicho gracias este mes

Message postés
61
Date d'inscription
miércoles, 26 de agosto de 2020
Estatus
Miembro
Última intervención
viernes, 28 de agosto de 2020
14
Exactamente, ese es el unico error que veo.
De lo demas esta bien
1
Gracias

¡Estamos felices de haberte ayudado! ¿Te hemos sido de ayuda? ¡Déjanos un comentario! Evalúa a CCM

CCM 35715 usuarios nos han dicho gracias este mes