Ayuda Lógica Programación

Cerrado
Wilf_8055
Message postés
4
Date d'inscription
jueves, 27 de agosto de 2020
Estatus
Miembro
Última intervención
viernes, 4 de septiembre de 2020
- 27 ago 2020 a las 22:23
DarylG45
Message postés
61
Date d'inscription
miércoles, 26 de agosto de 2020
Estatus
Miembro
Última intervención
viernes, 28 de agosto de 2020
- 27 ago 2020 a las 23:58
Hola a todos. Me asignaron un enunciado en la empresa, lastimosamente desconozco si mi resolución es la correcta. Me seria de gran utilidad si pudieran señalar algún error o sugerencia. Desde ya muchas gracias.





Asignar los valores de los datos de prueba a cinco variables. Ordenarlos en forma
ascendente usando una sexta variable como auxiliar. Posteriormente efectuar
la suma de las dos primeras y al resultado restarle la suma de la tercera y la cuarta.
El resultado multiplicar por la quinta y dejar el resultado final en la sexta.
Todo esto se debe hacer sin destruir los contenidos de las demás variables. Imprimir
el resultado final.

DATOS DE PRUEBA: 3 7 -3 -6 -16



ENTORNO
W_A es numerico
W_B es numerico
W_C es numerico
W_D es numerico
W_E es numerico
AUX es numerico
W_RESULTADO es numerico

CUERPO PRINCIPAL
inicio
ejecutar PROCESO_INICIAL
ejecutar PROCESO_PRINCIPAL
ejecutar PROCESO_FINAL
fin

PROCESO_INICIAL
imprimir "Asignación de valores"
leer W_A
leer W_B
leer W_C
leer W_D
leer W_E
retorno

PROCESO_PRINCIPAL
Sino
Imprimir E
Imprimir A
Imprimir B
Imprimir D
Imprimir C

FinSi

W_RESULTADO = ((W_A + W_B) - (W_C + W_D)) * 5

AUX = W_RESULTADO

retorno

PROCESO_FINAL

Imprimir "Auxiliar" AUXILIAR

retorno

2 respuestas

misterdekus
Message postés
468
Date d'inscription
miércoles, 10 de enero de 2018
Estatus
Miembro
Última intervención
miércoles, 1 de junio de 2022
120
27 ago 2020 a las 23:56
El único error que veo es este....

Sino
Imprimir E
Imprimir A
Imprimir B
Imprimir D
Imprimir C

FinSi

El Sino y FinSi esta de más si no tienes el si ( condición) entonces

Igualmente A , B , C , D y E , no existen
A lo mejor quisiste decir W_A , W_B , etc

Solo corrige eso , por lo demás está bien
1
DarylG45
Message postés
61
Date d'inscription
miércoles, 26 de agosto de 2020
Estatus
Miembro
Última intervención
viernes, 28 de agosto de 2020
37
27 ago 2020 a las 23:58
Exactamente, ese es el unico error que veo.
De lo demas esta bien
1