Problema con la funsion SI [Cerrado]

Denunciar
Message postés
2
Date d'inscription
miércoles, 27 de mayo de 2015
Estatus
Miembro
Última intervención
jueves, 28 de mayo de 2015
-
Mazzaropi
Message postés
1833
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
-
Tengo que buscar una formula para calcular un royalty variable en función de unas ventas y la formula que aplico solamente me funciona con dos importes y con otros dos no ( marcados en amarillo), entiendo que pueda ser un tema de paréntesis pero no logro encontrar el fallo.
Me podéis ayudar por favor
Muchas gracias

2 respuestas

Message postés
1833
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
276
casisolo, Buenas tardes.
La explicación es confuso.
No hay una fórmula aquí marcada amarilla.
casisolo
Message postés
2
Date d'inscription
miércoles, 27 de mayo de 2015
Estatus
Miembro
Última intervención
jueves, 28 de mayo de 2015

Ya veo lo que paso, lo inserte como una imagen, el libro Excel y por eso no se ve.
la formula es esta:
=SI(C32<$E$17;$C$17%;SI(C32>$D$18<$E$18;$C$18%;SI(C32>$D$19<$E$19;$C$19%;SI(C32>$D$20;$C$20%))))*C32
Donde C32 son las ventas, las columnas D y E son los limites de ventas y C17,C18,C19 y C20 son los porcentajes, lamento indicarlo así, pero como no hay opción a enviar el libro Excel,
muchas gracias
Message postés
1833
Date d'inscription
lunes, 16 de agosto de 2010
Estatus
Contribuidor
Última intervención
miércoles, 30 de mayo de 2018
276
casisolo, Buenas tardes.

No puedo entender cómo en algunos casos han funcionado.

La fórmula es con errores lógicos y sintaxis.
1) $C$18% - Excel no entiende esto como referencia de celda.

2) C32>$D$19<$E$19 - No se puede hacer comparaciones con esta sintaxis.

Trate de usar esta fórmula como mi sugerencia:
= SI(C32 <= E17;C17; SI(Y(C32 >= D18;C32 <= E18);C18; SI (Y (C32 >= D19;C32 <= E19); C19; C20))) * C32

Por esta su caso, la función BUSCARV sería mucho más eficiente y más fácil de mantener en el futuro.

Por favor, díganos si la fórmula funcionó para usted.

¿Era eso lo que querías?
Espero haber ayudado.