Problema al anidar Función SI

Cerrado
DrOcto
Message postés
2
Date d'inscription
domingo, 12 de junio de 2016
Estatus
Miembro
Última intervención
lunes, 13 de junio de 2016
- 13 jun 2016 a las 03:44
Hola, tengo una tabla de excel que en virtud de la cantidad de pedidos realiza descuentos sobre los productos (cuando se adquieren 6 se hace un 5% de descuento, mientras que cuando se adquieren 12 se hace un 10% de descuento). Cuando se adquieren 8 productos por ejemplo, 6 de ellos serían con el 5% de descuento y los otros 2 restantes sin descuento.

Pero el problema radica cuando los productos tienen 3 precios distintos, ya que hay que ponderar. Puedo hacer que me calcule el proporcional de cada uno para llegar al "paquete" de 6 o 12, pero no puedo hacer que me calcule cuando hay 7, 8, o más, ya que para ello tiene que ponderar el primer pack de 6 y el resto sin descuento. Me explico?

Hasta el momento la fórmula me queda así:
=SI(SUMA(G19:G24)=6;(((G19+G20+G22+G23)*D19)+(G21*D21)+(G24*D24))*0.95;SI(SUMA(G19:G24)=12;(((G19+G20+G22+G23)*D19)+(G21*D21)+(G24*D24))*0.9;SI(SUMA(G19:G24)<6;((G19+G20+G22+G23)*D19)+(G21*D21)+(G24*D24);)))

G19:G24 (está la cantidad de productos que se pide)
G19, G20, G22, G23 (tiene un precio)
G21 (tiene otro precio)
G24 (tiene otro precio distinto)