Error al instalar dual boot en BIOS uefi

Cerrado
AlunT Message postés 2 Date d'inscription martes, 16 de septiembre de 2014 Estatus Miembro Última intervención martes, 16 de septiembre de 2014 - 16 sep 2014 a las 23:10
Un saludo:
Recientemente me he hecho con un equipo por piezas, algo más actualizado que mi anterior sistema. En él, he intentado recrear los sistemas que tenía en el anterior (windows + ubuntu). En definitiva, he intentado poner un windows 7 home premium (original, cd prestado) 64bit conviviendo con un ubuntu 14.04 64bit. Ambos los estoy intentando instalar en un HD SATA de 500GB, y así tener los otros dos (1 y 2TB) para datos. El problema es, primero, que al particionar el HD, no me deja extender una partición (no tenía ninguna extendida, todas primarias), y luego, creo que esto viene por el nuevo sistema de BIOS, los uefi, si tengo una única partición con windows 7, arranca bien, pero cuando hago más particiones para meter ubuntu, me da error al arrancar (archivo winload.efi).
La pregunta es, ¿cómo puedo poner estos dos sistemas a convivir en mi equipo,y tener un dual boot como lo tenía antes? Aclaro: antes tenía un XP con un ubuntu en una placa con BIOS Legacy, sin uefi
Mis características son estas:
-Placa madre MSI X79A-GD45 plus
-HD Samsung HD502JI 500GB (aquí intento instalar los sistemas)
-HD Hitachi HDT721010SLA360 1TB
-HD Western Digital WD20EARS 2TB
-Procesador I7-4820K
-RAM HyperX Fury 4GB x2

Las particiones en el HD las he intentado hacer de esta forma:
-100GB NTFS primaria para Windows 7 (me creaba dos particiones de 100 y 128MB al principio del disco al instalarlo)
-2 GB primaria para la swap
-100GB ext4 primaria para Ubuntu
-Resto ext4 primaria para datos varios

Agradezco cualquier ayuda posible, sobretodo con el tema de las particiones, que me andan dando problemas, y con la BIOS uefi, que no la conozco muy bien aún...

Muchas gracias.