Como resolver condicion logica

Cerrado
Denunciar
Message postés
2
Date d'inscription
lunes, 24 de marzo de 2014
Estatus
Miembro
Última intervención
martes, 25 de marzo de 2014
-
WEAFFY - 25 mar 2014, 18:47 Te agradezco tu atencion ,

Explicare un poco mas claro para que se entienda....

A B C
1 Fecha Inicial Dias Rezagados STATUS
2 20/03/2014 5 ~

EN DIAS REZAGADOS SE LLEVARA A CABO SIEMPRE Y CUANDO LA CELDA C2 = ~ .
PERO SI EL STATUS TIENE EL VALOR " X " , LA CELDA B2 TIENE QUE CONSERVAR EL
VALOR ACTUAL Y NO DEVOLVER EL VALOR FALSO ¿ COMO ?

PARA B2
=SI(C2=" ~ ",HOY() - B2)
LA RESPUESTA QUE ME DISTE =SI(C2=" ~ ",HOY() - B2,4)
UNICAMENTE DEVUELVE EL NUMERO 4 SI EL CASO ES FALSO, NO QUIERO ESO


CASO NUMERO 2

A B C D
1 Fecha Inicial Dias Rezagados STATUS Dias Efectivos
2 20/03/2014 CERRADO X 5


AQUI UTILIZO OPCION SI FUERA FALSO B2 =SI(C2="~",HOY()-A2,"CERRADO")
AQUI ES FALSO EXISTE UNA " X "

EN LA CELDA D2 =SI(B2="CERRADO",HOY()-A2

EL PROBLEMA ESTA CUANDO MODIFICAS A2 DELIBERADAMENTE, ES DECIR
SI TIENES 20/03/2014 Y LE PONES 22/03/2014 TE DEVUELVE EL VALOR
3 EN LA CELDA D2 . TIENE QUE QUEDAR FIJO A PESAR DE MODIFICAR

ESPERO ESTA VEZ ME HAYA EXPLICADO

GRACIAS