0
Gracias

Unas palabras de agradecimiento nunca están de más.

Firefox: Forzar la compatibilidad de las extensiones




Si instalaste una extensión para Firefox y no es compatible con la versión de Firefox que utilizas, este artículo te será de mucha ayuda. El problema de incompatibilidad puede ocurrir al utilizar una versión beta, alfa o nightly de Firefox.


Sugerencia

El autor de este artículo no ha tenido ningún problema al utilizar las recomendaciones dadas en este artículo. Sin embargo, por cuestiones de seguridad te recomiendo hacer una copia de seguridad de tu perfil utilizando MozBackup o manualmente.

Deshabilitar la verificación de compatibilidad

Si ha habido cambios significativos entre la versión de Firefox para la cual ha sido creada la extensión y la versión de Firefox que utilizas, aun así es posible hacer correr la extensión. Para ello, será necesario deshabilitar la verificación de compatibilidad de las extensiones. Luego, en la barra de direcciones, escribe: about:config y acepta la advertencia que aparece. Haz clic derecho sobre la lista y selecciona Nuevo > Lógico, introduce el nombre de preferencia: extensions.checkCompatibility. A continuación, elige el valor (true: verdadero o false: falso), en nuestro caso: false. Después, reinicia Firefox.

Para volver a habilitar la verificación pon el valor en true.

Firefox no funciona correctamente después de esta manipulación

Si después de haber realizado esta modificación, alguna extensión hace que se cuelgue el navegador, reinicia Firefox en modo seguro, pon el valor de las extensions.CheckCompatibility en true y reinicia Firefox normalmente.

Si tu perfil hubiera sido alterado, restáuralo con MozBackup o manualmente.

Para saber qué módulo es el que está ocasionando problemas puedes deshabilitar todos, luego habilítalos uno por uno hasta que Firefox se cuelgue. Luego deshabilita el módulo problemático.

Solución al error de compatibilidad en la versión 5 (y posterior) de Firefox

A partir de la versión 4 de Firefox, se pueden tener problemas de compatibilidad en las extensiones debido a que ya no están siendo actualizadas. Para solucionar este problema, basta con instalar la extensión Addon Compatibility Reporter. No obstante, algunas extensiones no pueden funcionar correctamente (e incluso no funcionar) y/o provocar conflicto con las otras extensiones.
0
Gracias

Unas palabras de agradecimiento nunca están de más.

Haz una pregunta
Nuestros contenidos son redactados en colaboración con expertos del ámbito tecnológico bajo la dirección de Jean-François Pillou, fundador de CCM.net y director digital en el Grupo Figaro. CCM es un sitio de tecnología líder a nivel internacional y está disponible en 11 idiomas.

Consulta también

0 Comentario