Denunciar

Fórmulas lógicas de excel [Resuelto/Cerrado]

Haz una pregunta NOEMÍ - Última respuesta: 23 nov 2017 a las 20:56 por robert
Hola,


Me podrías decir para que sirven las siguientes fórmulas lógicas de excel =SI =SI(Y( =SI(O(

Vota
+165
plus moins
Funciones lógicas: funciones que nos permiten "preguntar" sobre el valor de otras y actuar según la respuesta obtenida.

SI
La función SI nos permite realizar una pregunta lógica, la cual pueda tener dos posibles resultados Verdadero o Falso y actuar de una u otra forma según la respuesta obtenida.

Estructura: SI(Pregunta lógica; Acción en caso verdadero; Acción en caso falso). Lo que escribamos dentro del segundo y tercer argumento serán las acciones que se realizarán en caso de que la respuesta a la pregunta lógica sea verdadera o sea falsa. Los dos primeros argumentos son los únicos obligatorios para esta función.

Para realizar la pregunta lógica podremos utilizar los siguientes operadores de comparación: = para preguntar si dos valores son iguales, > para saber si un valor es mayor que otro, < para preguntar por menor, >= con este podremos conocer si es mayor o igual, <= preguntamos por menor o igual, o si deseamos mirar sin son diferente utilizaremos <>

Ejemplo: Imagina que en la celda A1 escribimos la edad de una persona y en la celda A2 queremos que aparezca el texto "Mayor de edad" en el caso que la edad sea igual o superior a 18, mientras que nos interesará aparezca "Menor de edad" en caso que la edad sea menor de 18. La función que deberíamos escribir sería =SI(A1>=18;"Mayor de edad";"Menor de edad") Observa que en el primer argumento preguntamos por mayor o igual que 18, si la respuesta a la pregunta es Verdadera se realizará el segundo argumento: "Mayor de edad", en cambio si la respuesta es falsa, realizamos el tercer argumento: "Menor de edad".




Y
Esta función suele utilizarse conjuntamente con la función Si. Nos permite realizar en lugar de una pregunta varias. Y sólo se realizará el argumento situado en la parte verdadero del Si en el momento que todas las respuestas sean verdaderas.

Estructura: Y(Pregunta 1; pregunta 2; pregunta 3;...)

Ejemplo: En la celda A1, introduciremos la edad y en la A2 la estatura de la persona medida en centímetros. En la celda A3 aparecerá el texto "Puede pasar" si la edad es mayor de 16 años y mide más de 150. En el caso que alguna de las dos condiciones no se cumplan, aparecerá el texto "NO puede pasar". =SI(Y(A1>16;B1>150);"Puede pasar";"NO puede pasar") Observa que toda la función Y(...) se escribe dentro del primer argumento de la función Si.


O
Esta función también se suele utilizar conjuntamente con la función Si. Con ella también podremos realizar varias preguntas dentro del Si y la parte que está en el argumento reservado para cuando la pregunta es verdadera, sólo se realizará en el caso que cualquiera de las respuestas a las preguntas dentro de la O sea verdadera.

Estructura: O(Pregunta 1; pregunta 2; pregunta 3;...)

Ejemplo: Utilizaremos el mismo ejemplo anterior pero dejaremos pasar si la persona es mayor de 16 años o mide más de 150. De esta manera con que se cumpla una de las dos aparecerá el texto "Puede pasar". El único caso que aparecerá "NO puede pasar", será cuando las dos preguntas no se cumplan. =SI(O(A1>16;B1>150);"Puede pasar";"NO puede pasar")
eddy- 10 dic 2011 a las 00:56
gracias por la ayuda pero sabes el problema que tenia era de fechas de nacimiento separado y queria saber quienes son mayores y menores para revisar una base de datos convertir en exel
emma- 8 feb 2012 a las 23:35
gracias me sirvio mucho gracias a esto pase la materia=p
Don HH- 15 feb 2012 a las 15:37
quiero poner dentro de la prueba lógica verdadera,...SI(A1>0; "MARIA TIENE" A1 "AÑOS"; " EL VALOR NO ES LOGICO"), sale error...la pregunta es...si se puede colocar dentro de una evaluación de la prueba, palabras textuales precedidas del valor ubicado en cualquier celda??
jogefuba2- 6 sep 2017 a las 05:11
muchas gracias, me ha servido para aclarar mi dudas con respecto a las condiciones del SI,
Responder
robert- 23 nov 2017 a las 20:56
muy buena explicacion, muchas gracias!!!!
Responder
Vota
+24
plus moins
tengo una tabla donde aparecen los dias de descanso de los trabajadores cada trabajador descansa diferentes dias y entra a trabajar en diferentes horarios y cambia de descanso cada 60 dias ejemplo si luis descansa lunes el empieza a trabajar en el turno 3 los dos primeros dias y los dos siguientes dias entra a trabajar en turno dos los otros dos dias entra a trabajar en turno uno ok como se puede hacer que al ingresar el su nuevo dia de descanso de luis que seria el domingo en los siguentes dias aparesca los turnos que entrara a trabajar
lunes martes miercoles jueves viernes sabado domingo
d 3 3 2 2 1 1 descanso anteriror

lunes martes miercoles jueves viernes sabado domingo
3 3 2 2 1 1 d descanso nuevo
dULCE- 28 oct 2011 a las 17:47
muchas gracias fue de gran ayuda su aportacion!!1
Vota
+16
plus moins
Un placer servir de ayuda

Los miembros obtienen más respuestas que los usuarios anónimos.

Ser miembro te permite llevar un seguimiento detallado de tus consultas.

Ser miembro te permite disfrutar de opciones adicionales.

¿Todavía no eres usuario?

¡Inscríbete, es gratis y toma menos de un minuto!