Denunciar

Cómo quitar #n/a de una fórmula en Excel [Resuelto/Cerrado]

Haz una pregunta LUILLI - Última respuesta: 9 mar 2017 a las 09:41 por cesar
Hola, QUISIERAS SABER COMO EVITO QUE EL RESULTADO DE UNA FORMULA EN EXCEL ME DE #N/A Y EN SU LUGAR ME DE CERO (0) O GUION (-)
Vota
+138
plus moins
puedes usar esta opcion de ejemplo:

=SI(ESNOD(BUSCARV(C5,B5,1,0)),0,(BUSCARV(C5,B5,1,0)))


saludos
¿Te sirvió esta respuesta?  
coffyandmilk- 8 abr 2016 a las 18:02
excelente dato, super !!!!!! el que sabe....sabe....el que no....es JEFE. jajaja
victor murillo- 25 jun 2016 a las 19:52
ayuda quitar N/A a esta formula
=BUSCAR(B24,Inventario!B5:$C$8)
Mazzaropi 1631Publicaciones lunes, 16 de agosto de 2010Fecha de inscripción ContribuidorEstatus sábado, 4 de noviembre de 2017 Última intervención - 25 jun 2016 a las 21:19
victor murillo, Buenas tardes.

Utilizar:
=SIERROR (BUSCAR(B24,Inventario!B5:$C$8), "")

Eso es lo que querías?
Espero haber ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
HUMBERTO- 28 ene 2017 a las 19:41
COMO SE QUITA EL N/A A ESTA FORMULA ME AYUDAN GRACIAS
BUSCARV(A2,'[Salidas de Bolsa Ene 2017.xls]TD Etiquetado'!$A:$B,2,0)
Responder
Reymidas 1Publicaciones jueves, 15 de septiembre de 2016Fecha de inscripción jueves, 15 de septiembre de 2016 Última intervención - 15 sep 2016 a las 21:55
También puede quedar la fórmula:
=SI.ERROR(tu fórmula),"")
y en la celda queda en blanco, ya no aparece el error.
Vota
+27
plus moins
=si.error(escribes tú fórmula,0)

Saludos
Ruben- 10 jun 2015 a las 17:59
muchas gracias, muy fue muy util, problema resuelto.
tecnoyucateco- 4 nov 2015 a las 18:51
gracias, me resolvio mi problema de formula que tenia en excel,
abramsayon- 12 nov 2015 a las 14:56
AL PONER ESTA FORMULA =TEXTO(C13,"mmmm") DA COMO RESULTADO enero sin digitar nada, no quiero que salga nada sin ingresar datos.....alguna idea por favor
jose- 5 sep 2016 a las 21:14
abramsayon =SI(C1="","",TEXTO(C1,"mmmm"))

utiliza esa formula.
Lobo- 18 dic 2015 a las 18:01
Sos un capo, gracias
Vota
+12
plus moins
Sencillo, usa la función esnod(), por ejemplo:

=SI(condición,verdadero,falso) da como resultado el #N/A, agrega la función ESNOD, aunque esto implica repetir la formula de nuevo, por ejemplo tendrías que usar otra condicional.

=Si(esnod(función),"",función), lo que quedaría de la siguiente manera al unir:


=Si(esnod(SI(condición,verdadero,falso)),"",SI(condición,verdadero,falso))

NOTA, el "" lo puedes sustituir por un valor o texto.
rachhh- 24 nov 2010 a las 20:24
hola

llevo el dia completo tratando de quitar el resultado !"#valor" que me da en una columna
y no puedo ..... la formula que estoy usando es encontrar() pero no me resulta ni con eserro ni con esnod
estare haciendo algo mal

porf ayudenme
Tito- 29 dic 2011 a las 15:56
Excelente explicaciòn, muchisimas gracias
rulxar- 20 sep 2012 a las 04:44
gracias . . . si funciono :)
Sebas- 17 jun 2015 a las 19:25
=SIERROR( BUSCAR(C$4:C$37;Productos!B$2:E$35);0)
Vota
+7
plus moins
En excel, ubica el cursor en la celda donde da el resultado #N/A, presiona F2 y copia la formula (sin el =). Presiona esc en el treclado y ahora persional el =.

En la barra de formulas de excel (que se activa cuando ingresas el =), busca la función SI y selecionala abrirá un asistente pero no le hagas caso todavia, después busca nuevamente en la barra de formula la función ESERROR, esto abrirá otra ventana del asistente. Aqui pega la formula que habiamos copiado en la celda.

Luego te devuelves a la barra de formula y ubica el cursor en SI (esto cambiara el asistente) y en verdadero digiya una -, si es falso vuelve a pegar la formula que habiamos copiado.

Esto validará la formula, si da error dejar un - , si da un valor, pues dejará este valor.
manco- 8 oct 2013 a las 04:07
chrisparam, EXCELENTE!!! Gracias.
Anonymous- 12 oct 2013 a las 21:24
=if(iserror( Asi se pone en el Inicio y al final de la formula se pone dos )) asia dentro y luego ,"","" y aqui pegas desde despues del error desde donde empiesa el Vlookup y lo vuelves a pegar y donde )) al final y listo ya desaparece
liiiiiiiiiiiiiiii- 7 jul 2014 a las 12:46
tengo una factura y me pone valor null porque no escribo nada en el código, para que desaparezca el valor si no escribo nada en el código como se hace? muchas gracias!!!
jesus_palace 5Publicaciones jueves, 7 de agosto de 2014Fecha de inscripción jueves, 7 de agosto de 2014 Última intervención - 7 ago 2014 a las 19:35
pueden ayudarme con esta formula, relaciono dos tablas en el vlookup, pero me sigue apareciendo el mismo error siempre, los datos que busca el VLOOKUP estan en ambas tablas solo que no me deja de marcar el error, ya intente de todo pero nada.
=VLOOKUP('061914'!B5,Sheet1!$C$3:$J$47,4,0)

al copiarlo en otras celdas me marca exactamente el mismo error #N/A
francki- 22 may 2015 a las 22:22
Lleva la tabla a la misma hoja
Vota
+1
plus moins
pueden ayudarme con esta formula, relaciono dos tablas en el vlookup, pero me sigue apareciendo el mismo error siempre, los datos que busca el VLOOKUP estan en ambas tablas solo que no me deja de marcar el error, ya intente de todo pero nada.
=VLOOKUP('061914'!B5,Sheet1!$C$3:$J$47,4,0)

al copiarlo en otras celdas me marca exactamente el mismo error #N/A
Vota
+1
plus moins
pueden ayudarme con esta formula, relaciono dos tablas en el vlookup, pero me sigue apareciendo el mismo error siempre, los datos que busca el VLOOKUP estan en ambas tablas solo que no me deja de marcar el error, ya intente de todo pero nada.
=VLOOKUP('061914'!B5,Sheet1!$C$3:$J$47,4,0)

al copiarlo en otras celdas me marca exactamente el mismo error #N/A
jesus_palace 5Publicaciones jueves, 7 de agosto de 2014Fecha de inscripción jueves, 7 de agosto de 2014 Última intervención - 7 ago 2014 a las 19:51
ya probé con estó y me dice TRUE
=ISERROR(VLOOKUP('061914'!B11,Sheet1!$C$3:$J$47,4,0))

pero lo que quiero es que arroje el resultado en numeros como formula que es...
Mazzaropi 1631Publicaciones lunes, 16 de agosto de 2010Fecha de inscripción ContribuidorEstatus sábado, 4 de noviembre de 2017 Última intervención - 7 ago 2014 a las 19:53
jesus_palace, Buenas tardes.

Inicialmente, la fórmula no tiene errores de ortografía.

Pero si '061914'!B5 no está en la columna C de la hoja de cálculo Sheet1 dentro del rango C3:C47, entonces aparece error.
jesus_palace 5Publicaciones jueves, 7 de agosto de 2014Fecha de inscripción jueves, 7 de agosto de 2014 Última intervención - 7 ago 2014 a las 20:18
efectivamente el dato que buscaba en la sheet1 no aparecia ordenado en la hoja
061914 y copiando los datos de uno por uno, por alguna extraña razon se quitan todos los "#N/A"

que ironía, muchas gracias por tu ayuda

saludos
jesus- 21 abr 2015 a las 20:23
muuuuuuuuuchas grax :)
Vota
+0
plus moins
hola, alguen me puede decir como hecer la formula para restar dos cantidades y que me de como respuesta la diferencia y otra que si meda un valor negativo esto se convierta en "0" o falso o nada....
Vota
+0
plus moins
hOLA,

Seria algo asi:

=if((A2-A3)<0;0;(A2-a3))
jesus- 21 abr 2015 a las 20:24
hola parece facebook
Vota
+0
plus moins
Exceleten ayuda gracias
cesar- 9 mar 2017 a las 09:41
gracias por tu aporte
Responder

Los miembros obtienen más respuestas que los usuarios anónimos.

Ser miembro te permite llevar un seguimiento detallado de tus consultas.

Ser miembro te permite disfrutar de opciones adicionales.

¿Todavía no eres usuario?

¡Inscríbete, es gratis y toma menos de un minuto!