Haz una pregunta Denunciar

Formula para sacar numero primo

lizzy - Última respuesta el 19 may 2016, 02:56
Hola,
necesito saber la formula para saber si es un numero primo o no
Sigue leyendo 

Respuesta
+20
moins plus
aqui la factorial de un numero echo por los alumnos de la UAP
mas facil no podria estar

Public Class Form1
Sub factorial()

Dim a As Integer = Val(Me.TextBox1.Text)

Dim c As Integer = 1

For i As Integer = 1 To a

c = c * i

Next

MsgBox(c)

End Sub

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
factorial()
End Sub
End Class
Deja tu comentario
Respuesta
+1
moins plus
leete esto http://es.wikipedia.org/wiki/F%C3%B3rmula_de_los_n%C3%BAmeros_primos y te vas a dar cuenta de la verdad
qeti- 28 sep 2011, 21:35
Hay qierro saber algo mas
ueur
Responder
la xamaquita- 22 mar 2012, 20:41
q bien .
todo esta bien pero no entendi
Responder
Zamuray- 28 mar 2012, 05:33
no me compete es demasiado sencillo......
Responder
BHN- 9 oct 2012, 17:42
no entiendo nada 3======================D
Responder
BHN- 9 oct 2012, 17:42
no entiendo nada 3======================D
Responder
Deja tu comentario
Respuesta
+0
moins plus
Hola estimado.

La siguiente fórmula puede servir. Es Matricial; es decir, una vez introducida en la barra de fórmulas no hay que pulsar Enter, sino que hay que pulsar a la vez Control, Mayus, Enter.

Se supone que el número lo tienes en la celda B2.
El resultado de la fórmula indicará VERDADERO si el Nº es Primo, y FALSO si no lo es.

=SI(ES.PAR(B2);FALSO;SUMA(--(MULTIPLO.INFERIOR(B2;FILA(INDIRECTO("1:"&ENTERO(REDONDEAR.MAS(RAIZ(B2);0)/2)+1))*2-1)=B2))=1)

Un saludo
epiro1 13Publicaciones lunes, 16 de mayo de 2016Fecha de inscripción viernes, 20 de mayo de 2016 Última intervención - 19 may 2016, 02:56
NOTA. Aunque la fórmula indicará que 2 y 3 no son primos, en realidad sí lo son.
Al parecer la fórmula es válida hasta el número 17.179.606.993
Responder
Deja tu comentario
El documento «formula para sacar numero primo» de CCM (es.ccm.net) se encuentra disponible bajo una licencia Creative Commons. Puedes copiarlo o modificarlo siempre y cuando respetes las condiciones de dicha licencia y des crédito a CCM.

¿Todavía no eres usuario?

¡Inscríbete, gratis y en menos de un minuto!

Los miembros obtienen más respuestas que los usuarios anónimos.

Ser miembro te permite llevar un seguimiento detallado de tus consultas.

Ser miembro te permite disfrutar de opciones adicionales.