Denunciar

Cómo restar fechas en Excel [Resuelto]

Haz una pregunta decarlos 1Publicaciones viernes, 28 de julio de 2017Fecha de inscripción viernes, 28 de julio de 2017 Última intervención - Última respuesta: 30 jul 2017 a las 13:57 por Mazzaropi
El problema es el siguiente:

se requiere una fórmula de excel para restar fecha anterior (a) de fecha reciente (b) con tres condiciones dadas en tres casos:
1er caso:
si fecha reciente es menor que fecha anterior, el resultado sea "fecha incorrecta";
por ej: fecha (a) 14/02/18 fecha (b) 14/02/17

2do caso:
si ambas fechas iguales, el resultado sea "1";
por ej: fecha (a) 14/02/17 fecha (b) 14/02/17

3er caso:
si fecha reciente es mayor que fecha anterior, el resultado sea la resta simple de las fechas.

por ej: fecha (a) 10/02/17 fecha (b) 14/02/17

Tengo las fórmulas por separado, funcionando.

Cual seria la fórmula para anidar las tres anteriores en una sola? Muchas gracias!
Vota
+0
plus moins
decarlos, buenos dias.

Gracias por el feedback.
Feliz en poder ayudarte
--
Belo Horizonte, Brasil.
Marcílio Lobão
Tu opinión
Vota
-1
plus moins
decarlos, Buenos dias.

Como usted ya tiene las tres fórmulas listas y funcionando individualmente, basta combinarlas así:

Supongamos:

A1 --> 10/02/2017
B1 --> 14/02/2017

=SI(B1<A1; "fecha incorrecta"; SI(B1=A1; 1; B1-A1))

¿Eso es lo que quieres?
Espero haber ayudado.
decarlos- 30 jul 2017 a las 01:31
Listo! muchas gracias. Obrigado!
Responder
Tu opinión

Los miembros obtienen más respuestas que los usuarios anónimos.

Ser miembro te permite llevar un seguimiento detallado de tus consultas.

Ser miembro te permite disfrutar de opciones adicionales.

¿Todavía no eres usuario?

¡Inscríbete, es gratis y toma menos de un minuto!