Denunciar

% negativo o positivo según resultado

Haz una pregunta xavierol 4Publicaciones jueves, 13 de abril de 2017Fecha de inscripción lunes, 17 de abril de 2017 Última intervención - Última respuesta: 18 abr 2017 a las 00:34 por Mazzaropi
Buenos dias, necesito fórmula para sacar el % de la diferencia entre dos valores. El % tiene que salir negativo o positivo según el resultado. Ejemplo:
OBJ. MENSUAL 671,44
H.Facturadas 359,16
DIFERENCIA -312,28
% es 53,49% pero al ser negativo no me sale el signo de restar i lo mismo si cambio los valores no me da positivo.
Que fórmula tengo que poner para que si el resultado DIFERENCIA es negativo que me salga el % negativo? o al revés, si el resultado DIFERENCIA es positivo.
Grácias
Ver más 
Vota
+1
plus moins
xavierol, Buenas tardes.

Supongamos:

A1 --> OBJ. MENSUAL --> 671,44
B1 --> H.Facturades ----> 359,16
C1 --> DIFERENCIA ----> -312,28
D1 --> 53,49

Formato de celda D1 como:
Menú Formato;
Costum;
En el campo Tipo Introduzca: #.##0,00% +;#.##0,00% -
OK

Eliminar el resultado 53,59 de la célula y poner esta fórmula:

D1 --> =SI(B1<A1; (B1/A1)*-1; B1/A1)

Por favor díganos si ahora la sugerencia trabajó para usted.
Espero haber ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
¿Te sirvió esta respuesta?  
Tu opinión
Vota
+0
plus moins
xavierol, Buenos dias.

En la celda donde ya es el porcentaje, como resultado, dar formato a esa célula como esto:

Menú Formato;
Costumbre;
En el campo Tipo Introduzca: #.##0,00% +;#.##0,00% -
OK

Era eso lo que querias?
Espero haber ayudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
xavierol 4Publicaciones jueves, 13 de abril de 2017Fecha de inscripción lunes, 17 de abril de 2017 Última intervención - 15 abr 2017 a las 17:27
No entiendo o no me funciona, la gráfica es la siguiente:


OBJ. MENSUAL 671,44
H.Facturades 359,16
DIFERENCIA -312,28
53,49
H.Facturades es un valor positivo y OBJ.MENSUAL es dodne quiero hacer llegar el H.Facturadas, la DIFERENCIA como es negativa el resultado tiene que ser % negativo y me sale positivo. Quiero que el valor 53,49 marque % y negativo o en el caso que sea positivo marque positivo.

Espero me ayudes. Gracias
Responder
Tu opinión
Vota
+0
plus moins
Buenas tardes, al poner tal y como e comenta usted me da error y no me deja realizar el cálculo. Podría enviarme la tabla con el cálculo hecho en xavierolivan@gmail.com ?
Tu opinión
Vota
+0
plus moins
xavierol, Buenas noches.

Para mantener la integridad del foro y seguir las reglas, no se puede enviar ayuda por correo electrónico.

Compruebe este ejemplo que hice para ti:
https://www.sendspace.com/file/p5vh3v

Espero que el ejemplo le ayudará de manera concluyente.
--
Belo Horizonte, Brasil.
Marcílio Lobão
Tu opinión

Los miembros obtienen más respuestas que los usuarios anónimos.

Ser miembro te permite llevar un seguimiento detallado de tus consultas.

Ser miembro te permite disfrutar de opciones adicionales.

¿Todavía no eres usuario?

¡Inscríbete, es gratis y toma menos de un minuto!