Cómo usar SI con las funciones Y, O y No en Excel

Agosto 2017

En este artículo te explicamos cómo utilizar en Microsoft Excel la función lógica SI junto con sus complementos Y, O y NO. Cada una de estas funciones pueden ser utilizadas dentro de las fórmulas a fin de hacer comparaciones lógicas entre los datos contenidos en una planilla de Excel. Para facilitar la comprensión, también se incluye un mapa visual que ilustra cómo los cambios simples en cada fórmula afectan los resultados.


Función SI

La función SI te permite realizar operaciones con los datos en función de una condición determinada. Devuelve un resultado si la condición es VERDADERA y otro resultado si la condición es FALSA. Las funciones SI pueden ser de dos tipos: aisladas, lo que significa que solo se aplica una condición a los datos; o anidadas, donde se aplican criterios múltiples para generar un resultado VERDADERO O FALSO.

Función SI aislada

Aquí hay dos ejemplos de una función SI aislada. En estos, solo se aplica una condición para generar los resultados:

Si el valor de las celdas en la columna A1 es mayor o igual a 19, entonces mostrar 20; en caso contrario, mostrar A1. La fórmula sería:

=SI(A1>=19, 20, A1)

Si los datos en A1 son Descuento, entonces restar 10 %, de lo contrario, mantener A1. La fórmula sería:

=A1*SI(A1=Descuento; 1-10%; 1)

Función SI anidada

A continuación algunos ejemplos de una función SI anidada. En estos casos, se aplican múltiples funciones SI a los valores de una celda, generando resultados que dependen de las condiciones evaluadas. Puedes observar que cada criterio está separado por el uso de un punto y coma y que el número de paréntesis que se usan al final de la fórmula depende del número de funciones anidadas:

Si el valor en A1 es mayor que 12, entonces mostrar continuar; si A1 es mayor que 18, entonces mostrar muy bien, de lo contrario mostrar satisfactorio. Pero si A1<=12, entonces mostrar mejorar. La fórmula sería:

=SI(A1>12, continuar, & SI(A1>18, muy bueno, satisfactorio), mejorar)

o

=SI(A1<12; continuar, SI(A1<18, continuar, satisfactorio, continuar, muy bien))

Si el valor en A1 es menor que 4, entonces mostrar muy mal; si A1 está entre 4 y 8, mostrar insuficiente; si A1 está entre 8 y 12, mostrar regular; si A1 está entre 12 y 16, mostrar bien; si no, mostrar muy bien. La fórmula sería:

=SI(A1<4; muy mal; SI(A1<8; insuficiente; SI(A1<12, regular; SI(A1<16; bien; muy bien))))

Función Y

A diferencia de la función SI, que puede funcionar en aislamiento con una condición dada, la función Y prueba una pluralidad de condiciones definidas por el usuario y devuelve VERDADERO si se cumplen todas las condiciones y FALSO si alguna de las condiciones no se cumplen.

Similar a otras fórmulas condicionales, tienes la capacidad de definir tus propios resultados para VERDADERO y FALSO. Aquí un ejemplo:

Mostrar ¡Señora Condesa! si se cumplen todas estas condiciones: A2 (sexo) = mujer, B2 (estado civil)=casada, C2 (cónyuge)=conde y D2 (puntuación)=presente; si no, mostrar Hola:

=SI(Y(A2=mujer, B2=casada, C2=conde, D2=presente); !Señora Condesa!; Hola)

Notarás que esta fórmula comienza con la función SI. Este uso le indica a Excel que estás a punto de aplicar algún tipo de fórmula lógica. Inmediatamente después de la función SI está la función Y y los datos, agrupados bajo el conjunto de paréntesis para aislar las funciones. Ten en cuenta que la condición VERDADERO (!Señora Condesa!) aparece antes de la condición FALSO (Hola). Ambos resultados están separados por un punto y coma, y se incluyen entre paréntesis.

Función O

La función O comprueba las condiciones definidas por el usuario y devuelve VERDADERO (o similar) si se cumple alguna de las condiciones estipuladas por el usuario y FALSO (o similar) si no se aplica ninguna de las condiciones. La función O es mucho menos absoluta que la función Y. Aquí un ejemplo:

Mostrar Piloto si A3 contiene una de las siguientes condiciones: avión, fórmula 1, moto; mostrar Conductor si A3 contiene automóvil o trabajo; si no, mostrar ?.

=SI(O(A3=avión, A3=fórmula 1, A3=moto), Piloto, SI(O(A3=automóvil, A3=trabajo); Conductor;?))

Función NO

La función NO devuelve un valor opuesto de un valor o expresión lógica suministrada por el usuario.

La fórmula =SI(ENT(A3)=A3; entero; decimal) también podría escribirse como =SI(NO(ENT(A3)=A3);

Del mismo modo, la fórmula =SI(A4 <> francés, extranjero, europeo) equivale a =SI(NO(A4=francés), extranjero y europeo).

Combinaciones

Las funciones Y, O y NO están frecuentemente asociadas con la función SI.

Lo más interesante de estas funciones es que, juntas, pueden utilizarse para crear un diagrama de flujo que sirva como representación visual del algoritmo de un problema. Cuando utilices estas funciones, asegúrate de que todos los paréntesis, así como los puntos y comas estén colocados correctamente para garantizar los mejores resultados.

Image: © Gerd Altmann - Pixabay.

Consulta también

Artículo original escrito por . Traducido por Carlos-vialfa. Última actualización: 19 de julio de 2017 a las 16:07 por Carlos-vialfa.
El documento «Cómo usar SI con las funciones Y, O y No en Excel» se encuentra disponible bajo una licencia Creative Commons. Puedes copiarlo o modificarlo libremente. No olvides citar a CCM (es.ccm.net) como tu fuente de información.